Kia Forum banner

1 - 10 of 10 Posts

·
Registered
2011 Kia Sportage SX AWD
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hi everyone, it's my first post to the forum. I own a 2011 Sportage SX AWD in Bright Silver and it's been having problems for the past 6 months. The brake warning light kept coming on while driving the car and the only way to turn it off was to stop and restart the car. Every time this reset the light. We brought it to the dealer around 3600 miles and they said it was an electrical thing and supposedly did something with the software. They checked all brake components and found nothing wrong with the brake system or the fluid levels. After that service everything seemed to be fine.

This Sunday (5 days ago) I turned on the car and the brake light was on again (it now has 7000 miles, and that was the 1 year anniversary of our ownership). I checked the parking brake and then moved the car a bit and everything seemed to be fine, but I had to restart the car for the light to go off. The fluid was fine and after that it didn't turn on again. Yesterday my mom drove the car and the light was on again.

Next, the steering wheel controls are now going wacky. While on the highway coming back after the brake light incident, the car started beeping and the Voice Commands came on- this happened three times and I just shut it off with the button on the wheel. I thought nothing of it... until I drove to the store Monday and then things got crazy. The volume up rocker on the steering wheel made the volume go down and the volume down on the wheel made the voice commands come on! I taped it on my iPhone and will post this soon.

I'm thinking there's some weird electrical stuff going on too because the car has been having trouble recognizing the key sporadically too. Thoughts? Thanks!!
 

·
Registered
Sportage SX Black Cherry
Joined
·
53 Posts
I had a similar problem with my brake light coming on. I had it at the dealer multiple times until they finally determined there was an issue with the switch as it relates to the pressure in the system. Per my work order here's what was done: "remove the brake pressure sensor and drill out the sample hole to 9/64 and inspected and repaired loose terminals at the brake pump and applied stabilatant". I haven't had the problem since. This doesn't explain your other electrical issues, but hope it helps.

FYI I've had so many issues with my car and so little help from Kia that it's currently waiting to be traded in once my new VW arrives in a few weeks. My advice? Get out while you can.
 

·
Registered
10 Optima LX, 12 Sedona LX
Joined
·
1,415 Posts
All of the steering wheels controls for audio share a common circuit. Sounds like a bad connection(high resistance) somewhere in that circuit. Each button has a certain amount of resistance, and if you add some more somewhere else in the circuit, its going to think a different button is being pressed.
 

·
Registered
2011 Sportage SX
Joined
·
123 Posts
My 2011 SX WD has been doing the same wierd stuff with the steering wheel controls! Sometimes they do not work for the audio volume control and I've also had the voice command come on asking for "Command Please" when I did not touch the button. I also had the voice command activate when I touched the metal steering wheel spoke next to the command button! oh-oh.... What's going on here???
 

·
Registered
2011 Kia Sportage SX AWD
Joined
·
6 Posts
Discussion Starter #5
It's been fine ever since and of course the dealer is going to say they can't reproduce the problem. It's going in sometime this week... FiremistSLK, have you had your dealer look at it? Any other strange electrical problems with your SX?

That new 2013 Acura RDX is looking better and better each thing that goes wrong with this Sportage. As much as I love it, our 2004 Honda Pilot which we just sold for this had absolutely nothing go wrong except for a faulty battery which caused the engine oil light to come on. Kia quality doesn't equal Honda quality, but we knew that coming in by not buying the CR-V. There's nothing out there with as many features and the same great styling, power, and MPG in an AWD small SUV package as the Sportage, which makes me really sad that there are many issues with the 3G Sportages.
 

·
Registered
2011 Sportage SX
Joined
·
123 Posts
No... Have not had the SX to the dealer in a while because I have not driven it much. Should be going in next week for routine stuff.. oil change, tire rotation etc. I'll have them check it out then. I also had the brake warning light come on for no reson, too. I'll have that looked at as well.
 

·
Registered
2011 Kia Sportage SX AWD
Joined
·
6 Posts
Discussion Starter #7
The Sportage went in last week for a new clockspring and has been fine since. The car has <9k miles in 16 months, so I'm doubtful it's going to fix it completely, considering other people's problems with the clocksprings.

Our brake warning light has been on and off the entire time of ownership- it's a very frustrating experience, and when it turned on when leaving the dealer, they finally believed us and did a software flash. Supposedly it's a software issue since there was full fluid and with 8k miles, the pads were fine too. What a strange car sometimes...
 

·
Registered
2011 KIA Sportage SX, 2016 Ford Focus RS
Joined
·
480 Posts
I have had the brake light 3 or 4 times. In my experience it has only been after driving on dirt roads. So mine I believe to be a sensor somewhere that is sensitive to dust
 

·
Registered
Joined
·
1 Posts
Hi everyone, it's my first post to the forum. I own a 2011 Sportage SX AWD in Bright Silver and it's been having problems for the past 6 months. The brake warning light kept coming on while driving the car and the only way to turn it off was to stop and restart the car. Every time this reset the light. We brought it to the dealer around 3600 miles and they said it was an electrical thing and supposedly did something with the software. They checked all brake components and found nothing wrong with the brake system or the fluid levels. After that service everything seemed to be fine.

This Sunday (5 days ago) I turned on the car and the brake light was on again (it now has 7000 miles, and that was the 1 year anniversary of our ownership). I checked the parking brake and then moved the car a bit and everything seemed to be fine, but I had to restart the car for the light to go off. The fluid was fine and after that it didn't turn on again. Yesterday my mom drove the car and the light was on again.

Next, the steering wheel controls are now going wacky. While on the highway coming back after the brake light incident, the car started beeping and the Voice Commands came on- this happened three times and I just shut it off with the button on the wheel. I thought nothing of it... until I drove to the store Monday and then things got crazy. The volume up rocker on the steering wheel made the volume go down and the volume down on the wheel made the voice commands come on! I taped it on my iPhone and will post this soon. http://www.youtube.com/watch?v=klaA9vFvp0w

I'm thinking there's some weird electrical stuff going on too because the car has been having trouble recognizing the key sporadically too. Thoughts? Thanks!!
my 2013 sportage just started doing the same thing. and the back up alarm that is supposed to just beep when I get near something alarmed one long continuous beep...going in this week to check it out...
 

·
Registered
2013 Sportage turbo (SX model in US)
Joined
·
210 Posts
I think that harness inside of wheel seem to have connection problem. I suggest that you replace entire harness. then it will be fine.
 
1 - 10 of 10 Posts
Top