Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2011 Kia Sportage LX
Joined
·
4 Posts
Discussion Starter #1
I have a 2011 Sportage LX with about 65k miles. In the last couple months, I'm having an issue with getting my car started after filling up with gas. It will start (kind of hesitantly), but I get a check engine light. If I turn the car off and start it again, it starts fine with no check engine light. Has anyone had this issue? I see that it's a common problem with Kia Souls relating to a purge valve, but when I asked my local dealer, they said that it would not be the same issue with a Sportage. A friend of mine has a code reader device, so I'm hoping he can see if that gives any indication. But, I'm hoping someone here might know just the fix also!

I've noticed that this occurs no matter what level the gas tank is at, and it's consistent no matter what the outside temperature is.

Thanks!
 

·
Super Moderator
99 Kia Elan 1.8L
Joined
·
11,709 Posts
It could be the gas cap or evap valve, but best get the stored error codes read at Autzone and go from there.
 

·
Registered
2019 Kia Sportage. SX with AWD. 2.0L Direct Injected Turbocharged & Intercooled Gas.
Joined
·
1,357 Posts
Your symptom sounds like a fuel pump low pressure. Next time you fill your tank, just turn the key on (almost start) and off 3-4 times. On the 4th try hit it all the way to engage the starter. If she fires right up its most likely the pump going out. Check the fuel line pressure at the service port under the hood and let us know what fuel pressure is static and running. Good luck!
 

·
Premium Member
Joined
·
185 Posts
Do you constantly use the same gas station?
 
1 - 4 of 4 Posts
Top