Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all!

A couple days ago my seatbelt light started randomly blinking from time to time. Some drives it will not blink at all and others it will do it multiple times. It usually blinks for 30 seconds or so and then stops. My seatbelt is hooked properly and double checked.

Now tonight, the headlights went off a couple of times while driving. They go off for a second or two then come back on.

Also, tonight when we started the car the radio and clock settings were all reset. The car initially seemed like it would not even start.

Does anyone know what the issue may be?

We recently installed an AllState Drivewise device on the vehicle, but I'm not sure that this would cause the problems we are experiencing. I just wanted to throw this in incase others had experienced issues with the devices.

I hope that someone can help. Thank you!

Jason
 

·
Registered
Joined
·
40 Posts
Sounds to me like you've got a loose ground somewhere. First thing to check would be your battery connections. From there, check anything that may have been disturbed when the Drivewise device was installed.
 

·
Super Moderator
1995 Procharged Mustang Cobra, 2021 Sportage EX
Joined
·
4,574 Posts
Sounds to me like you've got a loose ground somewhere. First thing to check would be your battery connections. From there, check anything that may have been disturbed when the Drivewise device was installed.
Good advise here!! :)
 

·
Registered
2013 Sorento Ex V6
Joined
·
291 Posts
Hey all!

A couple days ago my seatbelt light started randomly blinking from time to time. Some drives it will not blink at all and others it will do it multiple times. It usually blinks for 30 seconds or so and then stops. My seatbelt is hooked properly and double checked.

Now tonight, the headlights went off a couple of times while driving. They go off for a second or two then come back on.

Also, tonight when we started the car the radio and clock settings were all reset. The car initially seemed like it would not even start.

Does anyone know what the issue may be?

We recently installed an AllState Drivewise device on the vehicle, but I'm not sure that this would cause the problems we are experiencing. I just wanted to throw this in incase others had experienced issues with the devices.

I hope that someone can help. Thank you!

Jason
If it seems to be a constant troubling thing that is happening, I think I would remove that Allstate "thingy" and see if the problem remains. :mellow:
 

·
Registered
Joined
·
1 Posts
Its not the allstate piece. I have been experiencing this for a year and my dealership says they cannot recreate the issue and has yet to be fixed. I plan to bring it back again as it is a hazard in bad weather or night driving when my lights turn off and on, not to mention people thinking I am flashing my lights at them.
 

·
Registered
Joined
·
1 Posts
Drive wise electrical issue

I realize this is an old topic but I can tell you for 100% certainty that Allstate Drivewise device did cause electrical issues with my 2011 Kia Sorrento. For over a month interior cabin lights would occasionally flicker and I'd hear a clicking noise in the fuse box. And my headlights occasionally flashed on and off. I was looking through the fuse panel thinking I may have a bad fuse and disconnected the Drive-wise device. Problem solved !! Has not occurred once since disconnecting it And I notified Allstate
 
1 - 7 of 7 Posts
Top