Kia Forum banner
1 - 4 of 4 Posts

·
Registered
2011 Sorento
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2011 Sorento.
2 days ago I was out doing errands. Last stop I made when I got back in the vehicle and turned it on I noticed my radio was off and the screen was blank. Thought it was weird as I always have the radio on and I know it wasn't off when I got out.
I pushed the button to turn the radio on and got static. Then noticed all the channels where set to the same channel and all my saved channels for all modes where gone. At this point I then noticed everything had changed back to the factory defaults.
Set radio stations all gone (am,fm and satellite), temperature back to Fahrenheit instead of Celsius, clock back to 12, millage back to miles instead of Kilometers, all my saved navigation map addresses gone and all the trip odometer readings reset back to zero.
Has anyone else experienced this or know why this could have happened.
Sure was a pain putting this all back in.:confused:
 

·
Registered
White 2012 SX AWD
Joined
·
843 Posts
This sounds like it could be something loose. Maybe a ground connection somewhere.

I also think I remember a TSB, a service bulletin, about a loose connector in service campaign 079.

This doesn't mean yours is affected or this has anything to do with your problem. Just something else to have checked by the dealer.

You can check the build date for your Sorento by looking at the sticker on the pillar when you open the driver's side door.

Some text from the notice:

NUMBER DATE
SC 079 February 2010
SUBJECT:
gRoUp MoDEl
Service 2011MY Sorento [XM]
Campaign
VOLUNTARY SERVICE CAmpAIgN TEChNICAL SERVICE BULLETIN
Kia Motors Logo 4/C - Medium
2011mY SORENTO [xm] EmS CONNECTOR INSpECTION
In some 2011MY Sorento vehicles with 2.4l engine produced from october 23, 2009
through December 14, 2009, and 2011MY Sorento vehicles with 3.5l engine produced
from october 23, 2009 through January 21, 2010 an EMS connector may not have
been properly snapped into place. Kia has identified two field vehicles which did not
have connectors properly snapped and wants to ensure maximum customer satisfaction
with this new model. Verify the vehicle is covered in the list of affected VINs. Use the
following procedure to check, and if necessary, correct the condition. Kia is requesting the
completion of this Service Campaign on all affected 2011MY Sorento vehicles in dealer
stock prior to retail sales.
This Service Campaign supercedes TSB ELE 012 (Service Action 029)
.
.
.
AffECTEd pROdUCTION RANgE:
MODELS PRODUCTION DATE RANGE
2011 Sorento [XM]
october 23, 2009 ~ December 14, 2009 for 2.4l equipped vehicles
october 23, 2009 ~ January 21, 2010 for 3.5l equipped vehicles
 

·
Registered
2012 Sorento EX AWD CRDI; 2007 Sportage EX CRDi 4WD; 1967 Mercedes 250S; 1958 DKW 3=6
Joined
·
372 Posts
One of my colleagues had a similar issue, and after several resets took it to the dealer. After a lot of checking etc they found that one of the connectors in the fuse compartment, the one that has three fat wires, was loose and caused the reset.

Worthwhile checking the connectors in yours I think
 

·
Registered
2011 Sorento
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the comments.
I checked with my Mechanic and the Voluntary Service call does not affect my Sorento. So that is good.
As for the loose connectors he wants me to wait and see if this happens again and then they will have a serious look at this.
 
1 - 4 of 4 Posts
Top