Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2011 red picanto TA,1.0, g3la, manual,
Joined
·
4 Posts
Discussion Starter #1
My picanto has 110 000km and started making a noise that sounds like a worn bearing.so naturally i checked and changed the aux belt idler pulley and also checked waterpump, alternator and aircon bearings.i came to the conclusion that it is the timing chain or tensioner.there is no noise in the morning when i start the car and only starts after driving for about 1km.i took it to my local kia dealer and the service agent told me that the noise is normal and that mine is not as bad or loud as others.he also said i should just enjoy the car and not worry about anything.(WTF?!) after driving away with my car i found the centre console cup holder broken off and neatly placed back to make it look like nothing was wrong.this totally made me think if this guy was just passing on a story that someone else gave him. Id rather fix it myself and stay away from that dealer and fix it myself since i do 180km per day so i dont want to be left stranded on the road.
the problem is i dont have the time over weekends to open the timing chain cover and confirm my suspicion .i want to know from forum members if anyone have experienced the same problem and at what milleage did it start?
 

·
Registered
2015 kia picanto 1.0L g3la
Joined
·
1 Posts
Is your car problem finished? at the moment I have the same problem. sound like a dry bearing, the sound comes from the top left of the engine. Is that the timing chain or the variable valve mechanism?
 
1 - 2 of 2 Posts
Top