Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2011 Optima LX GDi 2.4L V4
Joined
·
1 Posts
Discussion Starter #1
K Fam,

Trying to determine the root cause of this problem. When I click the Hazard button to flash my blinkers, nothing turns on. No sounds, no lights.

However, my left and right blinkers on the steering column assembly work just fine. I can turn on my left and right blinkers independently.

Is this a fuse? Do I need a new hazard switch?

If so...where is the fuse? Is there a how to video on Hazard switch replacement?

Thanks all

-G
 

·
Registered
Kia Rio 2013 auto
Joined
·
147 Posts
K Fam,

Trying to determine the root cause of this problem. When I click the Hazard button to flash my blinkers, nothing turns on. No sounds, no lights.

However, my left and right blinkers on the steering column assembly work just fine. I can turn on my left and right blinkers independently.

Is this a fuse? Do I need a new hazard switch?

If so...where is the fuse? Is there a how to video on Hazard switch replacement?

Thanks all

-G
here is how to remove the hazard button: Kia Optima: Crash Pad. Repair procedures - Interior - Body (Interior and Exterior) - Kia Optima TF 2011-2020 Service Manual

TBH i don't know how your turn signals work and not your hazards, because they are parts of a whole that must be connected in order to function. Try disconnecting the battery, removing the hazard button, re- attach the battery and see if any turn signals work (they should not), with the dash panel still removed, reattach the hazard button, ensure it is moving when trying to click and there is free moving function. If this dose not help then the only logical thing is the button is bad. Just my 2 cents.
 
1 - 2 of 2 Posts
Top