Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi gang! I have a '09 Kia Spectra EX.. <80k miles. Lately, I've been dealing with something interesting. I've noticed some interference when driving coming over the radio and speakers. While driving, I get static, and sometimes I can hear a whine while accelerating. I checked out the alternator, was bad, so I replaced that today. I have power, and everything seems fine again, however, I still have this interference. It's only on certain channels ranging from 100.1 - 106.1. It doesn't happen all the time, usually, it's just static ... But this is boggling my mind. What in the world could be causing this?
 

·
Registered
Joined
·
1,873 Posts
Happens with a lot of vehicles in the "rust belt" areas of the Northeast USA...Check the antenna coax cable at the base of the antenna for corrosion. you may find you will need to replace the antenna and cable. Strange you find it in FM(?) and not the more common AM side.

Another possibility is a weak(breaking down) spark plug wire causing static pick up in the radio.
 

·
Super Moderator
Joined
·
6,854 Posts
A very common problem is cause by cheap cell phone charges plugged into the cigarette outlet or other devices added on the car by the owner... The "clue" is the frequencies that switching power supplies operate at...They "switch" at fairly high frequencies and the harmonics of these "dirty" noise makers can/will affect radios...

Just something to check out... I've experienced this "problem" in my cars...
Dave
 
1 - 3 of 3 Posts
Top