Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My '09 Borrego 4WD with the 4.6 liter engine has a hesitation right off of idle and at about the middle of the accelerator travel. It also feels like its surging sometimes when I hold the pedal steady. Two Kia dealers have checked it out but they can't find anything wrong. There are no "trouble" codes stored and the check engine light doesn't come on. One dealer even checked the MAF and TPS sensors and said they were working OK.

Anyone else have this problem with their V8 Borregos? If so, were you able to get it diagnosed and fixed?
 

·
Registered
Joined
·
18 Posts
My V8 is a pooch out of the hole in comparison to other v8's I have had. I notice more when the truck is idle and getting hotter than normal. Cold it seems to be much more responsive wich leads me to believe it is built in protection for the engine.

About 2500 RPM the thing just plain takes off though! It is VERY quick in building speed from 2500 R's to 6000 R's. Remember its a SUV and not a race car!
 

·
Registered
Joined
·
3 Posts
Eric

My '09 Borrego 4WD with the 4.6 liter engine has a hesitation right off of idle and at about the middle of the accelerator travel. It also feels like its surging sometimes when I hold the pedal steady. Two Kia dealers have checked it out but they can't find anything wrong. There are no "trouble" codes stored and the check engine light doesn't come on. One dealer even checked the MAF and TPS sensors and said they were working OK.

Anyone else have this problem with their V8 Borregos? If so, were you able to get it diagnosed and fixed?
Yes have the same problem. Carred to dealership and I don't believed they believed me.But same occured and going back tomorrow and show them a print out of yours. Thats about the only problem other than door gaskets leakingg and replaced all them . Eric
 

·
Registered
Joined
·
103 Posts
My V8 is a pooch out of the hole in comparison to other v8's I have had. I notice more when the truck is idle and getting hotter than normal. Cold it seems to be much more responsive wich leads me to believe it is built in protection for the engine.

About 2500 RPM the thing just plain takes off though! It is VERY quick in building speed from 2500 R's to 6000 R's. Remember its a SUV and not a race car!
I too have the V8 and it used to have the hesitation. My wife drives a Hyundai Genesis V6 and it too had the hesitation...until I found a simple fix on the Genesis Forum. Make sure you read my post (last one on page 2).
Dead pedal / “Engine falls flat” potential fix.. - Hyundai Genesis Forum

This link has more info:
Secondary air door/A.K.A Flapper door Experiment - Hyundai Genesis Forum
 

·
Registered
Joined
·
1 Posts
Hello All, I'm new to the forum and I was hoping to get some feedback on this particular issue. I was just gifted an EX 4WD v8 Limited and at the risk of sounding ungrateful, the vehicle hasn't run right from the beginning. That is unless i just don't know how it's supposed to run.

I have the same issue as described above but my Malfunction indicator did come on recently. There was a slight vibration almost like a misfire and hesitation when I accelerated and for me it just seemed like little power for a v8 or even a v6 for that matter. The local dealer said they found an Evaporation System Leak Code? They ran a leak check and pressure tested the gas cap but came back with no verdict. They reset the codes and that evening when I picked it up it seemed like a new car. Smooth and little hesitation and more power.

The next morning it went right back to running the same way. The light hasn't come back on but it's definitely not running right.

I'll wait until the light comes back on since it didn't sound like this dealer could do much more other than check the plugs, which I doubt are the problem because I don't see how resetting the codes would have helped. Then again, I am not a mechanic which is why I'm here asking you all for advice.

Also, if there is anyone on the forum in the Raleigh/Durham area, I'd love to get any recommendations for a good dealer service department or mechanic that knows this vehicle well. Thanks in advance to anyone who can help.
 

·
Registered
Joined
·
2 Posts
I had the same issue however my local dealership quickly diagnosed the issue. I had a broken valve return spring. Covered under warranty and the engine has been flawless for almost 70K miles (just about to turn 100k). Wish Kia still made these vehicles in the USA. Awesome vehicle, great handling and fuel mileage and also excellent for towing (trailer weights to just over 7000 lbs). Hope you get your issue resolved.
 
1 - 7 of 7 Posts
Top