Kia Forum banner

1 - 10 of 10 Posts

·
Registered
2008 Kia Sorento EX
Joined
·
14 Posts
Discussion Starter #1 (Edited)
Ok so I am unable to install pioneer 6.5 correctly due to the original door speake connections that connect the old speakers does not match the new 6.5 pioneer 2ways I have. so i cut the harness on the stock speaker connector and what im left with is 4 wires that are, yellow (positive+),blue(negative-), white and black. The New speak only has spots for 2 spots to connect to so I matched yellow to my positive on the New speak and blue to the negative on the New speaker so I am left with the white and black wires with nowhere to go . I have it hooked up the same in the passenger door and all I'm getting is sound from the woofer part of the new speakers. I need to know how and where i need to connect the loose black and white wires to make the tweeters work. Please o please will somebody please explain to me how to wire my speakers so the tweeters Will work as well. You will be helping me out more then you know. Thank you and have an great night.
  1. Kyle.
    114827
    114828
    114829
    114830
    114831
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,981 Posts
"aftermarket speakers" does say much about them, and I'm sure you know that there's loads of different types and makes available - don't you think it would be useful to provide a little more detail?

You could even post a photo of the connections on the new aftermarket speakers.

How did you determine that the tweeters aren't working?
 

·
Registered
2008 Kia Sorento EX
Joined
·
14 Posts
Discussion Starter #3
"aftermarket speakers" does say much about them, and I'm sure you know that there's loads of different types and makes available - don't you think it would be useful to provide a little more detail?

You could even post a photo of the connections on the new aftermarket speakers.

How did you determine that the tweeters aren't working?
I added for info on the original post. I hope that gives a little more info. I'll take pics when i take the door panal off again.
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,854 Posts
Not to mention if you are connecting to a Kia amp (under seat) or an aftermarket head unit. Not sure about all US variations as we (UK) never had fitted amp, but have an idea some came with crossover units in the main speakers (and thence to tweeters).
 

·
Registered
2005 Sorento EX light blue, 2013 Lincoln MKZ Pearl White
Joined
·
76 Posts
Ok so I am unable to install aftermarket speakers correctly due to the door speakers plugs that connect the old speakers does not match the new 6.5 pioneer 2ways I have. so i cut the harness on the stock speaker connector and what im left with is 4 wires that are, yellow (positive+),blue(negative-), white and black. The New speak only has spots for 2 connections so I matched yellow to my positive on the New speak and blue to the negative on the New speaker so I am left with the white and black wires with nowhere to go . I have it hooked up the same in the passenger door and all I'm getting is sound from the woofer part of the new speakers. I need to know how and where i need to connect the loose black and white wires to make the tweeters work. Please o please will somebody please explain to me how to wire my speakers so the tweeters Will work as well. You will be helping me out more then you know. Thank you and have an great night.
Kyle.
Hi, I went through the same problem with my 2005 Sorento. The aftermarket does NOT make a replacement speaker for this speaker. It has separate leads for the mid-range and woofer off of the amplifier. I've been trying to find some for 8 years, no luck. Change the tweeters and "bite the bullet" on the door speakers. Joe
 

·
Registered
2008 SORENTO EX
Joined
·
86 Posts
Sorry, not much of an audio guy, but maybe you can get some insight from these guys who had a similar issue...

 

·
Registered
2008 SORENTO EX
Joined
·
86 Posts
Sorry, not much of an audio guy, but maybe you can get some insight from these guys who had a similar issue...

Just make sure I would go + to + and - to -...you may need a wired diagram to figure out which is which...and I would try first at low power to make sure nothing 'smokes'...
 

·
Registered
2008 SORENTO EX
Joined
·
86 Posts
1 - 10 of 10 Posts
Top