Kia Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello. My wife and I just bought our son a 2008 Kia Sorento. We love the vehicle, but about a month ago the lights on the instrument cluster went out. All of the intruments are working, just no lights. We took it back to the dealer and they said it was a faulty cluster and that we needed to purchase a new one. I just need to know if there is a bulb that can be replaced or do we need to replace the whole cluster. The lights for N D R and so on are still working. Thanks in advance for any help.
 

·
Registered
2009 Sportage, 98 Sportage, 2012 Tata Xenon, 1944 Jeep
Joined
·
515 Posts
I hate to be so simplistic but check the light control near the bottom corner of the dash has not been accidentally turned down. It is easy to bump when getting in and out of the car.
 

·
Registered
2006 Kia Sorento 3.5 5sp Auto
Joined
·
267 Posts
Also if that switch is faulty, or not plugged in, there wont be any lights on the dash.
When i was working on the car i forgot to plug it, and thought wtf did i do. After plugging in it worked again.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
not the switch

That switch was the first thing I tried. When it is turned down other lights, radio are, dim. Its just the cluster lights. Again, all of the other lights on the cluster work like the D N R. And the lights showing cruise headlights and so on work. Thanks for the reply.
 

·
Registered
2009 Sportage, 98 Sportage, 2012 Tata Xenon, 1944 Jeep
Joined
·
515 Posts
A bad earth or broken circuit track on the back possibly. You might be able to re-solder it in that case. Of course a dealer would just want to toss it and make you buy a new one. Maybe a good Auto electrician would be a better bet.
 

·
Registered
2003 sorento lx 3.5 4wd
Joined
·
86 Posts
mine does this occasionally and I do a fonzy trick and hit top right corner above instrument cluster and they come back on mine is caused by loose connection to the cluster I have had it apart checked connections but never permanent fix but fonzy trick works for me
 

·
Registered
2006 Kia Sorento 3.5 5sp Auto
Joined
·
267 Posts
haha, "fonzy fix" Next wime its apart try spraying some electrical contact cleaner and allowing to try...
Might help a litte.
 

·
Registered
2003 sorento lx 3.5 4wd
Joined
·
86 Posts
it is the far right connector the last of the three and I tried cleaner and di-electric grease even spreading and making sure I had good connection I think it is either in cluster or bad wire but fonzy never let me down yet aaayyy:thumbsup:
 
1 - 8 of 8 Posts
Top