Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
MF1717, post: 2010977, member: 465638"]
Hello everyone,
I am new and excited of this Kia lovers/users forum.
I am looking for help in solving my issue:
2007 Sportage v6 2.7
210,000 and kicking, pretty happy with it since new, no major issue other than regular maintenance and new water pump and timing belt replaced about 4,000 ago.
Issue now:
Started to have pretty bad gas mileage, about 8 miles per gallon and engine sputtering, and sometimes stalling at idle.
List of parts replaced in the past month:
-Pcv valve OEM
-Throttle position sensor OEM
-Mass air flow sensor OEM
-Idle Speed control OEM
-NGK spark plugs wires
-NGK laser Platinum spark plugs
-Air charge temperature sensor OEM
-Air intake sensor
-Canister purge control valve OEM
-6 fuel injectors OEM
-All 4 o2 sensors
-Both "Runners" at each side of the exhaust manifold.
The throttle position sensor I read, after installation, that needs calibration?,
I haven't done that and yesterday I removed the wire to the mass air flow sensor, as per Google suggestion, engine kept running, had not sputtering but hesitation and some vibration accelerating while driving. Also yesterday I removed the MAF sensor, cleaned it with MAF cleaner, as well as cleaned the throttle body with throttle body cleaner, connected all back and the sputtering is less noticeable but still s there, as well as bag gas mileage.
All of this and no code whatsoever, just got a code yesterday for removing the connector of the MAF.
Tomorrow I will replace the bank 1 catalytic since it's being throwing Mena P0420 code from time to time but it goes away a week later, so I will replace that catalytic.
Please help, does the TPS needs to be taken to the dealership for calibration?, I don't want to take it to the dealership, because I have been way over my budget, but
Do I have to take it to the dealer run that special in-depth diagnosis people frecuently speak about? How much does it cost that special diagnosis at the dealer?
Thanks in advance
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks Forte ounces for the reply,
I will do that once I replace the bank 1 catalytic, but the engine feels very strong and responsive for 210,000 miles, I don't think is clogged but will try. Lucky me I have a relative helping with replacing the parts and have found original parts very cheap on eBay and Rockauto.
But how about the TPS , does it needs to be calibrated?, And how about when the MAF sensor is disconnected that the sputtering stops? Any idea?
 

·
Registered
2006 Kia Sportage EX 2.7L
Joined
·
38 Posts
You're right, there should be power loss if there was an exhaust restriction.

I don't know about the calibration of TPS. I just searched and could not find the answer. I would think the TPS would be slotted for adjustment like the others that require calibration. Was there any change when you replaced the TPS? You could always reinstall the original.

I have heard of the MAF test. I've read that also causes the 02 sensors and to be ignored so it's likely but not guaranteed the MAF.

Hope you figure it out.
 

·
Registered
Joined
·
3 Posts
hpefully it’s not the cats. They are expensive. I had a similar issue and I threw new spark plugs, fuel pump, and after installed a cheap $20 MAF from Amazon it fixed the issue. My OEM was causing the issue. Dot forget to disconnect negative terminal before messing with the MAF, it is very sensitive and can go bad with power connected.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks
Good suggestion,
I will buy another MAF and do the battery disconnection,bI didn't ndo it, perhaps that's the issue.
 
1 - 7 of 7 Posts
Top