Kia Forum banner

1 - 10 of 10 Posts

·
Registered
kia rio5
Joined
·
27 Posts
Discussion Starter #1
My 2007 1/2 Kia Rio started having a problem staring after refueling at 80,000kms in March of 2010. it would idle rough, rev from 500-2000rpms. Having a hard time keeping it running. Like starting it up right after getting gas. It would take 2 minutes of turning the key having the engine start and hit 2000 rmps and dies before it would stay running. and it doesn't mater what speed your doing. if you push the clutch in . the car stalls out. it would hesitate. like the car would drop to 500 rpms and would not respond with the clutch and gas right to the floor for about 2 minutes before the engine starts to to clime rough till it hits 2000rpms then fly's right up to 5000 rpms without a problem. if its 25c or hotter out and you've been driving for about 40 minutes on the highway. its worse when you refuel. If the car is sitting in the hot sun till about 5pm with out being moved all day. when you driving it and come to a stop about 500 meters after driving. The car would hesitate and wont move. My car isn't giving any codes as to whats wrong.

I have taken it to 2 different dealerships with this problem. they have replaced my gas tank, fuel pump, o2 sensors, 2 canisters, and a canister close off valve, both dealers, head office and district manager dont know whats wrong with my car. I took it to my mechanic and he did a cold to hot reading of my sensors of my car. he found the my map sensor was bouncing between 1-37 psi at an idle, purge valve is open at 34% at an idle, and my cam adjustment is 659 degrees at an idle. This test was done with my car having a full tank of gas. the district manager gave me the reading of my map sensor of my car at an idle which its suppose to 15 psi at an idle. Both dealerships, head office and district manager have wiped their hands clean of this car. And they might help me out if i can find whats wrong with my car.

I was think that it could be my computer since it seems like it has a hard time getting the right reading from my sensors and it thinks everything is running okay. Any help would be greatly appreciated
 

·
Registered
kia rio5
Joined
·
27 Posts
Discussion Starter #4
the canister has been replace twice and the valve once. and still didnt make a difference when it comes to my refueling problem
 

·
Registered
kia rio5
Joined
·
27 Posts
Discussion Starter #5
now when I refueling my car will give either p0301, p0302, p0303, or p0304 if I let the car ideal after refueling and don't gun it after refueling. It would continue to missfire till you let the car sit for about an hour then it runs fine when you restart it.
 

·
Registered
Joined
·
8 Posts
I too would like to know what the root cause of this issue is. This is what is going on with ours. The purge valve was replaced and this still occurs.
 

·
Registered
kia rio5
Joined
·
27 Posts
Discussion Starter #8
not sure what started this problem but it since this problem started back in march of 2010. It keeps proving to me that my ecu aka computer is the root cause of the problem. I"m hoping when i take my car in next month to have the ecu replaced it solves my problems or most of them. I'll keep you guys posted on if that solves the issue
 

·
Registered
2006 Kia Rio, 2010 Hyundia Sonata, 2013 Hyundia Elantra
Joined
·
7 Posts
My
Wife's car had the same problem. I replaced the purge control valve. Fixed it for a short time. It ended up being a combination of the purge valve and 2 bad coil packs. Also turn the key to acc and see if you hear the fuel pump kick on.
 
1 - 10 of 10 Posts
Top