Kia Forum banner

1 - 6 of 6 Posts

·
Registered
2007 Kia Rondo 6 cylinder
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi, Thanks in advance for assisting!!.

I have a 2007 Kia Rondo...40,000 miles on it. For the past couple of years, I have noticed a pattern on my Kia. I always thought it was the battery, but replaced recently.

My issue is... when driving, the headlights, and any other lights that are on, are fine.. when approaching a stop light, or stop sign, or for any reason that prompts a release of the gas pedal, all lights dim for a quick second, then come back normal, and stay that way till I go back to the pattern stated above.

They go partial dim, not completely dim.

This has been happening for at least:confused: a year, I always thought it was the battery, but had replaced it... and for months still does it.

When the car is parked, but still running... I stepped on the gas pedal and then let go, and it dimmed as soon as I let go of the pedal. Also, still with the car parked and on.. I turned on the interior lights ( at night) and without touching the gas pedal or anything... I did notice the dome lights flicker ever so lightly but noticeable.

Any guesses?

I tried to look for the information but did not find anything completely related to this.

Thank You

Anthony
 

·
Registered
2009 Carens crdti LS 2.0 diesel
Joined
·
47 Posts
Sounds like it's possibly the alternator regulator - usually on end of alternator where cables connect. worth getting an auto electrician to check for you.

A brief check would be to check battery volts whilst engine running at fast speed and see what voltage reading you get when closing throttle. It should be about 14v when charging - my Carens runs at 14.1v in normal running, drops to 13.8 briefly when lifting off but goes back up to 14v within a second or so.Engine off reading is usually about 12.5v.

could also be a bad ground connection on battery.

HTH
 

·
Premium Member
2016 FIAT 500X Trekking Plus AWD; 2016 Kia Forte5 SX 1.6T A/T
Joined
·
6,805 Posts
not that it is generally speaking NORMAL, but some of us suffer from this issue.
It was found on several models across KIA without any good resolution.

The voltage drops to about 11.5V only when RPM drops quickly from above 1500 to idle, and only in range of about 800-600 you may notice the "flashing".
No CEL, no codes. Otherwise, charging is fine.

I got same and I stopped noticing it.
 

·
Registered
2007 Kia Rondo 6 cylinder
Joined
·
27 Posts
Discussion Starter · #4 ·
Voltage

Thank you PLP and Quiltman,

PLP, I was surely confused and your answer is greatly appreciated.

I always thought it was the battery but last March I had Kia put a new one in and they always do a 21 point inspect.
 

·
Premium Member
2016 FIAT 500X Trekking Plus AWD; 2016 Kia Forte5 SX 1.6T A/T
Joined
·
6,805 Posts
they always do a 21 point inspect.
yeah... the 21 point inspection.
Once they told me I got left less than 2 mm on my rear pads. Heck, I thought, it is time to get them done.
When I put them apart, all rear pads had more than 4 mm. :confused:


Anyway, as for the problem. It could have existed before, but you did not notice...
I tested it (tracked voltage) several times, I showed that to service dept a few times - they were saying "normal thing". Sure...

I would accept - we can't find a solution for it. We heard, we saw, but are unable to fix it now instead "it's normal".

If you still have warranty - keep complaining. Maybe they will find a solution.
I have never had any problem to start the car or any electrical failure so that I assume charging is fine. Voltage was stable (at idle) regardless of load: nothing to all lights, defroster, stop lights, hazards, blower on max...
 

·
Registered
2007 Kia Rondo EX-V6 Luxury, 1990 Suzuki Escudo
Joined
·
254 Posts
Hi, Thanks in advance for assisting!!.

I have a 2007 Kia Rondo...40,000 miles on it. For the past couple of years, I have noticed a pattern on my Kia. I always thought it was the battery, but replaced recently.

My issue is... when driving, the headlights, and any other lights that are on, are fine.. when approaching a stop light, or stop sign, or for any reason that prompts a release of the gas pedal, all lights dim for a quick second, then come back normal, and stay that way till I go back to the pattern stated above.

They go partial dim, not completely dim.

This has been happening for at least:confused: a year, I always thought it was the battery, but had replaced it... and for months still does it.

When the car is parked, but still running... I stepped on the gas pedal and then let go, and it dimmed as soon as I let go of the pedal. Also, still with the car parked and on.. I turned on the interior lights ( at night) and without touching the gas pedal or anything... I did notice the dome lights flicker ever so lightly but noticeable.

Any guesses?

I tried to look for the information but did not find anything completely related to this.

Thank You

Anthony
Hi Anthony,

We had a very similar problem since the car was new. Trying to convince Kia we had an issue to begin with was at least a year long odyssey. Kia tested our regulator several times and said it was good.

Kia ended up replaced the alternator regulator under warranty. Someone from Kia came from Asia for the Soul launch in Canada and we got a last minute call to bring the car in, this fellow had something to do with trying a "fix" for the light dimming problem. It still does it a bit under certain circumstances, but is much better.

Curt
 
1 - 6 of 6 Posts
Top