Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Kia Rio5 2007
Joined
·
1 Posts
Discussion Starter #1
2007 kia Rio Engine shuts off intermittently.
History:
1 year ago we had an issue with rough engine and power issues (Approx 150k). replaced spark plugs and same issue. Engine light codes reported misfire on cylinder 3&4. replaced both coil packs for those cylinders and no problems since.
Then out of the blue a couple of months ago the engine would just shut off randomly, no bogging or rough idle, just the engine would stop running. this would happen usually when slowing to a stop, making a slow turn or at a drive through(lots of times at tim hortons...beginning to think it is allergic to coffee!) while the engine is drive and foot applied to the brake.
Funny thing is that you put it neutral and crank the engine and it would fire right back up.
Other problem that is likely related is that intermittent you get a very slight very brief hesitation while driving.
Replaced:
Battery
Fuel filter
then fuel pump ($200 that included fuel filter)
then one time got an engine light that said misfire on cylinder 1.
replaced both coil packs for cylinder 1&2 since both 3&4 were replaced a year ago.
fuel pump relay.
replaced all belts including timing belt.
Have taken this in to a shop to run a diagnostic machine and nothing can be found, they even did a road test and of course the issue did not present itself.
Today(09/27/2012) the engine shut off while slowing on a highway at an off ramp. This time it did not start right away. After looking at the engine dumbfounded and about 10 minutes after I was about to have a truck tow it and dump it in the lake it started up again. Completed the remainder of my trip (10k) and then return home (highway) about 65k and did not present any issue with stalling or hesitation.
I am at wits end. no codes but just shuts off. I have seen the same issue posted all around the internet for this issue and if someone has the answer then i will be forever grateful...otherwise a trade in is in the cards that I don't want to do. Besides this issue the car has been great.
 

·
Registered
2007 Rio5, 2012 Sorento EX-V6
Joined
·
113 Posts
It sounds to me like a iacv (idle air control valve). Between this and the throttle position sensor is how the ecu controls/senses you are at idle. If this is only happening while letting off the throttle, could be the culprit. Hope this helps!!
 

·
Registered
Joined
·
1 Posts
Mine did this for almost a year before I got it fixed. It is either going to be the crank sensor or the cam sensor. Mine finally gave me a code for both so I replaced both and it fixed the problem. Hope this helps
 

·
Registered
2007 Rio5 M/T
Joined
·
40 Posts
I just went through very similar symptoms. Codes P0337 and P0339. After some tailchasing, replaced the crankshaft position sensor and that fixed the problem.
 
1 - 4 of 4 Posts
Top