Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2006 kia spectra sx
Joined
·
3 Posts
Discussion Starter #1
i bought my sx a month ago. when I bought it the tranny fluid was really dirty like motor oil colored and over-full. I had the dealership flush the fluid and fix the o2 sensor and now I've noticed it revs high when in park and shifts hard. it doesn't feel like it's slipping but it's not shifting smoothly. this is the first car I've ever bought from a dealer, no warranty, no knowledge, car payment, and a little freaked out. any suggestions? oh, and I don't have a whole lot of money to work with. :eek:
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,938 Posts
Revving in park....
Clean the IAC (idle air control) valve and butterfly valve inside the throttle body..It gets gunked up with carbon and soot then sticks.

Transmission fluid...
Depending on the mileage on the car..having the transmission fluid "flushed" usually is NOT a good idea on a high mileage (+100k miles) car..

You also did not mention if the transmission fluid FILTER was replaced (internal)..
After stirring up the "gunk" laying in the bottom of the transmission with the "flush" it may now be plugged up with the gunk... The valve body passageways also may be plugged causing shifting problems...
A regular here (Loyale 2.7 T) had problems with his spectra transmission and he ran a bottle of SeaFoam Transtune in it then dropped the fluid pan and cleaned out the gunk...

His words "
So, Today I went to our Local NAPA Store and I obtained a Can of "SEAFOAM Trans Tune" and I poured it all (a pint) to the actual ATF; then I Drove the Car for an Hour on Traffic.
My plan is to drive it for a couple of Hours more tomorrow and then I will Remove the Transmission's Bottom (Oil Pan?) to Clean it all with Kerosene;"
and..
"
Then I will Close it and Pour new, Fresh Oil and Try it Again... I Hope that will fix it, because today Driving with the Seafoam, I Noticed Smoother Shiftin' and also I Noticed that the Overdrive button on the Shifter, Still Works! ... ... Because the Transmission downshifted when I pressed the O/D button, and it Returned to Shift Up when I pressed the O/D button again; like if it where working Normally."
This is the tread it is located in...
http://www.kia-forums.com/2g-1998-2001-sephia/76263-2000-sephia-blinkin-o-d-light.html
I'd say try the Seafoam Trans Tune, and then have the pan dropped and cleaned ...have the internal filter replaced... and have the transmission fluid replaced with Valvoline Maxlife transmission fluid...
ABSOLUTE worst case "if" the transmission has to be replaced they are very reasonably priced "used" with low mileage (under 40k miles) check car-part.com and/or ebay.
We are here to help...So don't give up just yet...
Dave
 

·
Registered
2006 kia spectra sx
Joined
·
3 Posts
Discussion Starter #3
thank you so much. this helps a lot. like I said I don't have any knowledge but thankfully my boyfriend works on cars for a living, but I bought this car by myself :/ the dealership didn't say anything about changing the filter. the only reason I had them flush the fluid was because when I checked it was almost black and I know that it's supposed to be red. and it was overfull which I know they do to create pressure and keep the tranny from slipping. after it was done I noticed it was shifting a lot harder. mine doesn't have an OD button either. don't know if that makes a difference?
 

·
Registered
2006 kia spectra sx
Joined
·
3 Posts
Discussion Starter #4
I knew I should have held out and waited to find a manual...it's what I really wanted lol
 
1 - 4 of 4 Posts
Top