Kia Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My Kia just started having a loud buzzing noise coming from the engine. My check engine light has been on for a while with no issues. Pep Boys did a free
check engine light test: p0038, p0420, p0136. Any idea what I'm looking at for
repairs?
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
You have a bad O2 sensor. The preheater portion of the O2 sensor is bad.
if you look at the front of the engine you will see an aluminum shield and in the center you will see what looks like a spark plug with a wire on it.. That's the O2 sensor. It should be a 10 minute job.
This would not cause your buzzing noise. If you can record a video and post a YouTube link we may be able to diagnose the noise.
Dave
 

·
Registered
06 Sedona LX, 06 Sedona EX, 14 Forte EX, 11 Sportage EX, 11 Forte 5-door SX, 15 K900 VIP+
Joined
·
1,143 Posts
OEM part number 3921023700, lists for $189.02 at the dealership. You can find the part anywhere from $125+ when you shop around online. Forum member cobra259 works for a dealership in Michigan and is a great resource for good prices on OEM parts. You might try sending him a PM.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
You are going to need an "upstream" or also known as a "pre-cat" O2 sensor.
Rockauto has them for $97 (NTK Part # 24353 NTK OE Type Wideband $96.79)
or if you are strapped for cash get one from LOW mileage salvage (donor) car at your local salvage/junk yard... To replace it it only requires a 7/8" wrench and 10 minutes time.
You did not state the mileage on your car... If it's above 140k miles it probably needs replacing... It's BAD to drive with the check engine light on and it can hurt other parts of the engine ( the catalytic converters for one).
Dave
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
I "see" you are in California so used O2 sensors will probably not be available..
You also won't pass emissions inspection and won't get a renewal on your cars plates.
Dave
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I have 84,000 miles on it. I really appreciate your help. I have zero support and no nothing about cars. I will try to do the sound thing. It only does it when the car is at idle....first noticed it in a drive thru. Once I'm driving it....no noise.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
About the noise....someone said it could be a problem with the A/c. It makes a growling type noise when I shut off the unit so I'm thinking its about to go out. It still works but could the noise be from it? It only does it when the car is at an idle ...even when the a/c is off.
 

·
Registered
Joined
·
10 Posts
The buzzing noise sounds to me like a motor mount. I have a bad mount/mounts in my spectra and there is a buzzing/vibrating noise when stopped at stoplights. If your steering wheel vibrates when in gear but not moving do a motor mount test.(pop hood, prop it up, hop in, start er up, look through the crack between dash and bottom of hood at the top of your engine, and do a brake torque(put it in drive, hold down brake and hit the gas a bit. If your engine moves alot, raises up alot, motor mount is bad. Do it again just like that but put it in reverse. See what happens.) I don't think you will get a check engine light from a bad mount.
 
1 - 10 of 10 Posts
Top