Kia Forum banner

1 - 5 of 5 Posts

·
Registered
2006 Sorento EX
Joined
·
2 Posts
Discussion Starter #1
I just replaced the timing belt, water pump, idler pulley, tensioner pulley, and both cam and crank sensors. Car ran for a few days then tried to start and it would not run. It cranks over and will pop sometimes like it wants to fire. I double checked timing its good. I did hear a possible vacuum leak the last time it started and the o2 sensors need to be replaced. Any suggestions would be very appreciated
 

·
Super Moderator
99 Kia Elan 1.8L
Joined
·
11,303 Posts
A quick and easy check is to use starter fluid, if it runs with that it confirms the timing and sensors are good and you have a fuel delivery issue.

If it doesn't start with the fluid, then do a compression test.
 
  • Like
Reactions: Lou O.

·
Registered
2006 Sorento EX
Joined
·
2 Posts
Discussion Starter #3
Update on my Sorento I was able to pull 2 codes with an OBDll (P0343) cam shaft postion sensor High input. And (P0101) Mass air flow sensor malfunction. I just replaced the cam sensor bought it brand new and drove less then 60 miles before it malfunctioned. Could this related to some other issue or just bad luck.
 

·
Registered
2011 Forte SX 2.4L (thankfully MPI) A/T 144K miles
Joined
·
1,508 Posts
... I just replaced the cam sensor bought it brand new and drove less then 60 miles before it malfunctioned. ...
How did you determine the sensor 'malfunctioned'? Did you do any electrical testing before or after the sensor was replaced?
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,883 Posts
P0343 = Typically the causes for this code are:
Open in the ground circuit to the camshaft position sensor
Open in the signal circuit between the camshaft position sensor and the PCM
Short to 5 volts in the signal circuit to the camshaft position sensor
Occasionally-Camshaft Position Sensor faulty – internally shorted to voltage
Read more at: P0343 Camshaft Position Sensor A Circuit High Input
Copyright OBD-Codes.com

I would be looking for a wiring issue first before the sensor.
 
1 - 5 of 5 Posts
Top