Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi i have a kia 2006 spectra obd port was working fine. now i get the rom error 2138913331 different numbers every time i plug in the scanner?. i also get DTC definitions found 3A33 that gives different numbers each time also. i also noticed the cigarette lighter fuse is lit up red like a light is on which i know isn't supposed to be red. i have tried everything but have exhausted all i could try. it says see service manual for DTC i have looked and cannot find anything on it. all fuses are good tested each one. the cigarette lighter fuse has me stumped that it is lit up red like it was a light. it runs fine drives fine it just started doing this recently after i fixed the exhaust leak i had it has me stumped would anyone have any idea whats going on. im sure the exhaust repair didnt do this battery is good reads 12.5 volts.not running. any help is greatly appreciated. ready to send it to the junk yard.lol
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
The first thing that strikes me is you did an exhaust repair.... Did you do some arc welding? Many cars are very sensitive to drawing an arc... It is always best to disconnect the negative battery wire and then short that wire to the positive wire with a clip lead... This brings the whole electrical system to an equal 0Volts... DO NOT short the battery terminals together only the loose negative wire to the positive wire... Then any welding can't damage any of the car's computers... If you are getting a "ROM" error then the stored programs within the ECM/ECU do not match the "checksum" and the stored memory has a byte that has changed from a 0 (zero) to a 1 (one) or visa versa from either a spike from welding or sometimes just from a loss of power... Try disconnecting the battery for a short while (like a minute or two) and then reconnect the battery... Some times these computers can get confused and need a total power down to reset them...

Now as far as the light on the cigarette lighter fuse....Someone has replaced that fuse with one that lights up a small LED located within that fuse... The LED being lit would indicate that the fuse we are talking about is BLOWN and needs replaced... The LEDs will NOT light "if" the fuse is OK...

Your DTC code doesn't make sense... The codes are usually P0XXX or B0XXX... where the XXX's would be numerical values like P0300, P0303.... The P codess are reference to the ECM/ECU (engine control module) and the B codes are reference to error codes stored in the BCM (body control module)...

You may have more than one fuse blown...causing all of your problems... you need to pull every fuse and check either optically (look for a burnt link) or electrically (using an OHM meter looking for continuity (zero resistance))...
Dave
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I did do some mig welding i did unhook battery but the positive slipped and was touching the pos post. But if i remember right it was doing this before i fixed the exhaust. i will check all fuses again and see if any are blown. I know i was getting the rom error before doing the repare. It will say ROM error and after about 30 seconds my Actron obd 2 scanner will say read codes.? then says no codes. it has me stumped. im pretty sure they exhaust leak code should still be there as i have not driven it to clear any codes. The DTC code as you said is strange for it dont show any codes to accompany it. i really dont want to sink anymore money into this car. I will check fuses i have unhooked battery but will also try that again also and let you know Thanks for such a detailed response
 
1 - 3 of 3 Posts
Top