Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I drove my sorento yesterday to go camping. Approximately 60 miles from home. Turn vehicle off and went into camp store to look at map for available sites and wait on family to arrive. Roughly an hour later tried to start car and it just clicked a few times. So I tried again and it did the same thing. I had no lights either. So I tried to jump it and it just clicked and the hot post sparked . Even then no lights. So today after it sat all night I tried to start it again and it still just clicks but my lights are back again. So I checked the battery with a volt meter and have 12.68 volts. With the lights on I have 11.99 volts. While trying to start it it has 12.56 volts as its clicking. So I pulled the battery and tried to jump the car straight to the cables and it still just clicks. So I don't think its the battery since I eliminated it from the car. Any help would be great as I don't want to pay a tow bill from 60 miles from home.
 

·
Registered
Joined
·
68 Posts
Having the same issue that you have only when I jump the battery the engine will start but quickly dies. My son drove the Sorento to the Bart station and parked it for approximately 8 hours and when he returned and tried to start the car the only thing that happened was clicking sound. I went to where the vehicle was a couple of hours later and jumped the batter and the vehicle started up and quickly died.
 

·
Registered
2009 Sportage, 98 Sportage, 2012 Tata Xenon, 1944 Jeep
Joined
·
515 Posts
Bad earth? Stuck starter solenoid? Unfortunately could be a number of things.
 
1 - 3 of 3 Posts
Top