Kia Forum banner

1 - 11 of 11 Posts

·
Registered
2005 Kia Optima
Joined
·
19 Posts
Discussion Starter #1
So I was forced to replace my cranks position sensor in an attempt to correct a non start issue...That repair proved pretty simple...Did it work?..Sadly I have no idea...In removing parts to gain access to the sensor my coil packs connection completely disintegrated.....I'm now left with the option of soldering in the connection permanently as opposed to the 100+ dollars for the new piece of harness,as well as what new packs will cost....MY ISSUE? I need to be absolutely sure I get the connections right..The connections are pictured below...I assume the solid color wires connect to the striped wire of the same color,that would leave the black,and blue to each other....Given past luck,and experience though I'm not willing to go on my assumption.
Does anyone know the proper connection?
Could someone peel back their wiring and look for me?
 

Attachments

·
Registered
KIA's 2000 Carnival, 2008 Magentis, 2005 Optima
Joined
·
561 Posts
So I was forced to replace my cranks position sensor in an attempt to correct a non start issue...That repair proved pretty simple...Did it work?..Sadly I have no idea...In removing parts to gain access to the sensor my coil packs connection completely disintegrated.....I'm now left with the option of soldering in the connection permanently as opposed to the 100+ dollars for the new piece of harness,as well as what new packs will cost....MY ISSUE? I need to be absolutely sure I get the connections right..The connections are pictured below...I assume the solid color wires connect to the striped wire of the same color,that would leave the black,and blue to each other....Given past luck,and experience though I'm not willing to go on my assumption.
Does anyone know the proper connection?
Could someone peel back their wiring and look for me?
Is it the 2.5 engine V6 or the 2.7 engine V6 or the 4 cylinder as they are completely different
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 2013 BMW K1600 GTL
Joined
·
11,140 Posts
Where are you located?

The only options I see are:
1) Search a wreckers yard.
2) Sign up with KGIS for $19 and download PDF's of all sections that you need.
 

·
Registered
2005 Kia Optima
Joined
·
19 Posts
Discussion Starter #7
Where are you located?

The only options I see are:
1) Search a wreckers yard.
2) Sign up with KGIS for $19 and download PDF's of all sections that you need.
I'm sad to say the junkyard option only occurred to me today...I will start following that option tomorrow..
I did download what I was told was the shop manual for my car here
https://www.tradebit.com/filedetail....-repair-manual
...sadly I don't trust my ability to read the schematics..I think I located the correct one,but I don't see the wire colors matching up..
 

·
Registered
2005 Kia Optima
Joined
·
19 Posts
Discussion Starter #9
Things I learned today..
No one is allowed in the junkyards anymore
If you're not buying a part no one is interested in helping you...
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 2013 BMW K1600 GTL
Joined
·
11,140 Posts
I'd have them snip the connector with a length of cable attached to splice to the existing wires.

Those schematics are generic - the ones on KGIS have the pin-out of the connectors with wire color codes.
 

·
Registered
2004 Kia Optima v6 2.7L
Joined
·
1 Posts
I have the same issue with my 2004 Optima. did you figure it out, I need help too... not working due to covid and car broke down so trying not to spend money I dont have...thank you for any help
 
1 - 11 of 11 Posts
Top