Kia Forum banner
1 - 3 of 3 Posts

·
Registered
2004, Spectra EX 2.0
Joined
·
2 Posts
Discussion Starter · #1 ·
Forgive me if this has been solved, but I recently purchased this vehicle for my teenager. I have replaced both the input and output speedometer sensors, and the Camshaft position sensor, due to a P0335 code. The Speedo works until the car reaches and is at running temp for about 10-15 minutes then cuts out. I have seen that maybe the fuse box, or the ECU. but was wondering if anyone has successfully solved this issue, before I dump more money on swapping "Maybe" parts.

Many Thanks, in advance!
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,959 Posts
Your post jogged my memory and I located this thread...
I hope this helps....
Be sure to REPLACE the timing belt if the age or mileage on it is unknown... Failure to do so can/will end up with you having a trashed engine... KIA also recommended draining and replacing the transmission fluid EVERY 30k miles in the automatic transmissions...Failure to do so can end up with a plugged valve body and major tranny problems... If the transmission fluid is bright red and not brown it is safe to replace the fluid... If it is brown or black you may be better off just leaving it as it is... KIA/Mazda/Ford built these trannys and they shed metal when driven and replacing the fluid kept the buildup from happening....
My daughter-in-law is driving a 2008 Spectra with 226k mile on it with only having to replace maintenance (wear) items... The engine and tranny are quiet and still very reliable... I have seen Spectras with 300k+ miles on them here on the forum...
Dave
 

·
Registered
2004, Spectra EX 2.0
Joined
·
2 Posts
Discussion Starter · #3 ·
Your post jogged my memory and I located this thread...
I hope this helps....
Be sure to REPLACE the timing belt if the age or mileage on it is unknown... Failure to do so can/will end up with you having a trashed engine... KIA also recommended draining and replacing the transmission fluid EVERY 30k miles in the automatic transmissions...Failure to do so can end up with a plugged valve body and major tranny problems... If the transmission fluid is bright red and not brown it is safe to replace the fluid... If it is brown or black you may be better off just leaving it as it is... KIA/Mazda/Ford built these trannys and they shed metal when driven and replacing the fluid kept the buildup from happening....
My daughter-in-law is driving a 2008 Spectra with 226k mile on it with only having to replace maintenance (wear) items... The engine and tranny are quiet and still very reliable... I have seen Spectras with 300k+ miles on them here on the forum...
Dave
Thanks, the link doesn't seem to work for me...
 
1 - 3 of 3 Posts
Top