Kia Forum banner

1 - 6 of 6 Posts

·
Registered
2004 Kia Rio Sedan 1.6L DOHC
Joined
·
7 Posts
Discussion Starter #1
Hey, guys. I've got a 2004 Rio that we repaired the engine on. Broken timing belt, screwed up head and holes in the pistons....The usual. So, now we've got it all back together and in the car. Timing was set before it was installed, so we know that's good.

For some reason, it's not getting spark. We tested the ignition coil for resistance and voltage going in the coil, following a guide on KiaTechInfo. The spark plug wire connectors on top of the coils tested within specs at around 11.7 K-Ohms. The plugs where the connectors plug in on the bottom tested a little higher then specs at around 0.6-0.7 ohms. Specs say withing 0.45-0.55 ohms.

The wires going into the coils tested at 18.8 volts. I think that's a little high, but I'm not an expert. Also, there's a code for the crank sensor. Could that be bad and disable the coil? The plugs do not spark if they're removed from the head and held to a ground.

One other thing I'm hoping you can all help with....When we got the engine in, we're not sure if we connected everything where it SHOULD be. Is there some kind of diagram or print-out that we can follow to make sure everything is plugged in where it should be?
 

·
Registered
2002 Kia Rio 2003 Dodge Durango 1993 Chevy C1500
Joined
·
95 Posts
What was the actual code that you pulled? As much as I can remember no two wire harnesses are the same, so chances are if they fit, they are correct. There ARE two small harnesses that plug right into the head that are for the injectors, those may be the same and fit into each others side, not 100% on that one though.
 

·
Registered
2004 Kia Rio Sedan 1.6L DOHC
Joined
·
7 Posts
Discussion Starter #3
I don't remember the code number, but it was for Crankshaft Position Sensor Circuit A Malfunction I think....Not 100% that's how it was worded, but pretty close. I know the Crank and Cam sensor connectors are the same, but I don't think I mixed them up since no code for the Cam sensor comes up....

I just need a chart that shows which connector goes to which plug in the harness if someone's got it.
 
1 - 6 of 6 Posts
Top