Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
hi

please help

on the road vehicle just like has weak fuel pump, i plugged scanner it showed
p0500 vehicle speed sensor
p0325 knock sensor malfunction

short term for b1,b2 are good . ignition timing 14-15 . sometimes to 16

when i press gas pedal ( at idle) rpm reach stuck on 5 and no more ,at this number engine start shaking .

can faulty knock sensor cause this?
is it catalytic converter?
is it timing

sorry for my bad english


thanks
 

·
Registered
06 Sedona LX, 06 Sedona EX, 14 Forte EX, 11 Sportage EX, 11 Forte 5-door SX, 15 K900 VIP+
Joined
·
1,143 Posts
when i press gas pedal ( at idle) rpm reach stuck on 5 and no more ,at this number engine start shaking .
This is because you are bouncing off the rev-limiter. Do not do this, it is bad for the car. So that you don't blow the engine, the car won't let you rev over a certain RPM, and what you describe is perfectly normal in this instance.

As for the code you got, yes, a faulty knock sensor would cause P0325.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
i can say it is not normal because number 5 on rpm gauge is before red line ( rev limit) .

fuel pump is good, catalytic converter b1 and b2 are without combs inside so no way to say they are restricted.
 

·
Registered
06 Sedona LX, 06 Sedona EX, 14 Forte EX, 11 Sportage EX, 11 Forte 5-door SX, 15 K900 VIP+
Joined
·
1,143 Posts
Yes, number 5 is before redline, but the car is designed not to go to redline unless it is in gear. In Park or Neutral you will bounce off the rev-limiter at 5, and it will make a terrible noise, shake violently, and kick black smoke out the exhaust. Don't do this, it is bad for the car. It sounds like you are having weak acceleration? Kia doesn't list a P0500 in their manual, but the other code you listed can be caused by a faulty knock sensor. A faulty knock sensor will cause engine hesitation and poor acceleration.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
i disconnected the manifold i didnt find knock sensor or even harness for the sensor , also injector 2,4 both didnt spray fuel while i was cranking engine ,injector 6 spray for a while then stop ,next cranks not. i found 12 v fr every injector harness , i am sure they are not clogged or faulty .

when i connected the manifold and turned on the engine all 2,4,6 injectors worked .

i guess that knock sensor is not installed on this model by kia company in korea or disconnected by someone when it was in worksop.

assume it is not installed on this model then i suspect timing ( jumped tooth) because engine starts after many attempts .
 

·
Registered
Joined
·
17 Posts
Any luck sorting out the speed sensor error code?

I have 2004 Kia Amnati and gettign service fault code p0500- vehicle speed sensor "A".

The car has 3 speed sensors: transaxle, transmission input, ans transmission output.

Anyone know which one is "A"??
 
1 - 6 of 6 Posts
Top