Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
its a 2003 kia sorento. car has 102000 miles.
car was running fine for 1 day after i changed the cam angle sensor. the next day, i started the car and it was running rough. check engine light came on stating that it was the #5 cylinder not firing. Determined that the coil pack was bad. So i removed the cover that exposes the 3 coil packs. I attempted to start the car in order to find out which coil pack it was that wasent firing (was gonna unplug them one at a time to see any change with the engine) only to find the car wont even start. I placed a wire in one of the ignition coil pack terminals and grounded it to the intake manifold expecting to see spark but nothing. no spark coming out of any coils. all the plugs and vaccume hoses are in. Checked all the fuses and all seem to be OK. The car cranks just no spark from any coil. Doubt that all the coils burnt out at the same time. Any advice would be appreciated. Thanks in advance.
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,496 Posts
Go back to the source of you original repair. Double check your cam sensor install. If it is not done right it will effect the rest of your trouble. Did you remove the Timing belt or crank sensor?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
figured it out. seems the crank angle sensor got pinched and cut so had to replace that (wasn't easy), however, i still need to replace the coil pack for the #5 cylinder as its still misfiring. Can u tell me which coil pack sparks the #5 cylinder? Theres 3 of them on the driver side. Each one appears to control 2 cylinder banks for spark. Just need to know which pack controls the #5 cylinder. Thanxs in advance.
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,496 Posts
First coil controls Cyl #2 and #5

See diagram
 

Attachments

1 - 4 of 4 Posts
Top