Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2003 GMC Sierra
Joined
·
2 Posts
Discussion Starter #1
Hello,
My son has a 2003 KIA Rio. Ha made a simple right turn the other day and since then,the car won't start. I first checked fuel pump fuse and swapped out relay. No change. The fuel pump wasn't working. Replaced fuel pump,no change. I then checked all fuses and found a blown ECU fuse which I replaced,no change and ECU fuse remains good at this time. The car will fire and run on starter fluid through air box.The car ran perfectly prior.I have been reading forums so I have rotated the ignition multiple times,no change. I have also disconnected and reconnected the battery. PLEASE HELP. Does anyone have any ideas or tests that may fix this. THANKS.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Maybe your ecm died or your main relay is bad or main fuse is bad out in the engine compartment. like fevrej says fill out your profile some more. If you live in the usa http://www.kiatechinfo.com/ for service materials electrical schematics and shop manual it's free. Good luck with it. Reguard's Ronjohn
 

·
Registered
2003 GMC Sierra
Joined
·
2 Posts
Discussion Starter #4
I live in southern Ohio,USA. I have checked main fuse. So i'm guessing maybe my next step will be to purchase an ECM and try replacing it. I'm guessing as long as I match the part numbers I should simply be able to swap this out without reprogramming? There are multiple used ECM's availabe w/return warranty on E-bay. Guess maybe i'll try this just to see what happens. Just wondering why the car fires and idles on starter fluid if the ecm is bad. GRR,LOL
 
1 - 4 of 4 Posts
Top