Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey everyone, I just bought an '03 EX back in March and it has the auto 4x4 option. Well we got our first big snow storm the other day and it isn't working. When I switch it to 4WD LO i can hear the transfter case engage I think and the indicator light comes on but I still get no movement out of my front wheels. I'm pretty new to to owning a KIA and the AUTO 4x4, so where should I even start? I should note I think I need new front wheel bearings if that plays into it.
 

·
Registered
2006 Kia Sorento 3.5 5sp Auto
Joined
·
267 Posts
Have a look at this forum

http://www.kia-forums.com/2003-2010-sorento-forum/56017-4-wheel-drive-wont-engage.html

It sounds like your hose may be cracked, and may just need to replace.
Real quick summary, the front diff (and hence 4wd if all other 4wd systems work as it seems yours are) is engaged by a little pump poping a diaphragm of some sort in the front diff, that forces the front diff to spin with the rest of the drive components. So follow the hose from the pump to the diff to see if there is a crack and the air from the pump is escaping.
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,878 Posts
Real quick summary, the front diff (and hence 4wd if all other 4wd systems work as it seems yours are) is engaged by a little pump poping a diaphragm of some sort in the front diff, that forces the front diff to spin with the rest of the drive components. So follow the hose from the pump to the diff to see if there is a crack and the air from the pump is escaping.
That does not apply to TOD model that OP indicates they have.
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,878 Posts
This will sound silly, but get underneath and check you actually have a shaft between transfer case and front diff! Not uncommon for front prop-shafts to have problems through lack of lube (or other mechanical failure) and the simple solution is to remove it.
 
1 - 4 of 4 Posts
Top