Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello,

I just purchased a 2002 Kia Rio with a 5 speed Manual Transmission. The speedometer and gas gauge do not work. I'm having a hard time finding useful information on the web and hoping to find help here. From my research, it sounds like I need to remove the transmission to replace the Vehicle Speed Sensor, I'm hoping I'm wrong. Additionally, it sounds like the Gas Sensor is tied into the fuel pump, so I'm guessing I have to replace the fuel pump?

Any help or advice would be much appreciated.

Thanks!
 

·
Registered
2014 Hyundai Veloster Turbo / 2001 Kia Rio
Joined
·
211 Posts
you are correct about the gas gauge, it's in the pump. easy under the seat. worst part is getting the bolts off the top of the tank. mine were corroded so i just left them, to deal with someday when i absolutely had to.

as for the vss, it's on the back of the trans and removal is not needed.

 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
you are correct about the gas gauge, it's in the pump. easy under the seat. worst part is getting the bolts off the top of the tank. mine were corroded so i just left them, to deal with someday when i absolutely had to.

as for the vss, it's on the back of the trans and removal is not needed.

Thank you so much! According to the below link and on an 01 Kia Rio with manual transmission, the mechanic said the transmission had to be dropped.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
yeah well, the manual and my experience tells a different story :)
i replaced the fuel sending unit and it is now working well. :) I also replaced the Vehicle Speed Sensor, but the speedometer is still not working. I ordered part #0K2A117400 after contacting Kia to verify the correct part. I installed it fairly easily, but the speedometer is not working. With the ignition on, I checked the voltage coming from the 3 wires to the VSS and I get 14 volts out of one pair and 10 volts out of the other pair, so it seems like the wiring is ok going to the VSS. I'm wondering if maybe I got a bad replacement VSS? Is there any other suggestions of what to check?
Thanks,!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Hi,I have recently purchased a 2003 kia Rio and the fuel gauge always reads empty.can you give me any advice on replacing or testing the sending unit? Where to find it ,access it etc.
Thanks
Hello, I used this video to help me get to it. The Fuel sending unit is attached to the fuel pump assembly. In my case, the black wire was broken.

 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
i replaced the fuel sending unit and it is now working well. :) I also replaced the Vehicle Speed Sensor, but the speedometer is still not working. I ordered part #0K2A117400 after contacting Kia to verify the correct part. I installed it fairly easily, but the speedometer is not working. With the ignition on, I checked the voltage coming from the 3 wires to the VSS and I get 14 volts out of one pair and 10 volts out of the other pair, so it seems like the wiring is ok going to the VSS. I'm wondering if maybe I got a bad replacement VSS? Is there any other suggestions of what to check?
Thanks,!
Sorry, I am re-posting this so my question/problem about the VSS doesn't get lost with the Fuel gauge problem. I had mentioned both problems in the same post because I didn't know if they were related somehow.

I replaced the Vehicle Speed Sensor, but the speedometer is still not working. I ordered part #0K2A117400 after contacting Kia to verify the correct part. I installed it fairly easily, but the speedometer is not working. With the ignition on, I checked the voltage coming from the 3 wires to the VSS and I get 14 volts out of one pair and 10 volts out of the other pair, so it seems like the wiring is ok going to the VSS. I'm wondering if maybe I got a bad replacement VSS? Is there any other suggestions of what to check?
Thanks,!
 
1 - 7 of 7 Posts
Top