Kia Forum banner

1 - 4 of 4 Posts

·
Registered
kia sedona 2.9tdi 01, isuzui trooper 3.1td, Transit 2.4 2000
Joined
·
54 Posts
Discussion Starter #1
Hi, Just got a strange fault started on my sedona.
It will change up 1st to 2nd as normal, but will not change into 3rd. It will stay in 2nd and speed will go up does not feel like slippage, you have to ease off revs then it will change to 3rd with a jump. The speed then goes up and the converter locks up. I have changed the oil twice now. When you have got oil up to temp it may sometimes not lock up converter.
Any help on this will be good.
 

·
Registered
kia sedona 2.9tdi 01, isuzui trooper 3.1td, Transit 2.4 2000
Joined
·
54 Posts
Discussion Starter #2
Update.
Tested input and ouput speed sensors both ok. Removed and checked both sensors both had a very small amount of swarf on ends.
Checked temperature sensor which was ok. Cleaned all electric connections etc. Road test fault still there. Feel like 1st and 2nd work fine, 3rd only comes in when at 45mph and lift off throttle a little. Does not feel like torque converter is locking up, so top speed is only about 65mph without over revving engine.
Tested throttle postion sensor, sensor faulty. Unpluged sensor and went on road test changed up 1st to 2nd then 3rd ok but still low top speed, hold light flashing on dash.
Fitted new sensor, but fault still there. Need to know how to reset the auto ecu.
 

·
Registered
kia sedona 2.9tdi 01, isuzui trooper 3.1td, Transit 2.4 2000
Joined
·
54 Posts
Discussion Starter #3
Hi. had codes read and tps p1121 cleared. still will not go in torque lock up (top gear).
Any help please.
 
1 - 4 of 4 Posts
Top