Kia Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hello my radio lighter clock not working its stuck in park and wont start i checked all the fuses and they are good changed both relays under the hood. there is not voltage present at the fuses when i checked with a vltmeter. is there anything i can do are check. thanks for all the help in advance
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,694 Posts
Start at the battery, clean all connections, then check all major grounds for corrosion.. Philip
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
checked battery connections clean all those still will not start ok if i touch 12volts to the radio fuse it will come on and i can get it out of park but it still wont start im so confused.
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,694 Posts
checked battery connections clean all those still will not start ok if i touch 12volts to the radio fuse it will come on and i can get it out of park but it still wont start im so confused.
You have an open circuit between the battery and the fuse box, use your meter, starting at the power source and follow until you locate the problem...

I use a non invasive circuit tone generator.... Philip
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #5
ok here is the lastest i was not able to find my tone generator and tracer however this is what i did i ran a wire from one the above fusess down to the bottom row and energized that row and behold the radio lighter clock worked and it started but when i turned the ignition switch off the car stayed running until i pulled the jumper wire off now im even more confused could this indicate a bad ignition switch. or what are your thoughts. thanks
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,694 Posts
No, the jumper you installed bypassed the switched side of the ignition....

You need to understand the wiring before you stab at it any more.... Philip
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
ok i will check the feed wire later on down the line mean while i put a toggle switch in hooked up between the second and third row of fuses and am able to drive the car i have to throw the switch one way to start and drive then when finish i have to switch it the other way to cut the engine off this is a quick fix for the time being i will follow up on the feed wire to the clock thanks.
 
1 - 9 of 9 Posts
Top