Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i really need help locating the camshaft position sensor on my 2001 kia sportage 2wdr manual transmission my check engine light stays on and my car is really sluggish and slow i had the codes ran twice and comes up with p0343 camshaft position sensor which is like $130 ordered my car has 111k on it and was trying to locate the sensor pull it and clean it real good before i go fork $130 for a new one even if i did that i wouldnt know were it goes noone at the autoparts stores know if some one can help me out a.s.a.p would greatly be appreciated thanks!
 

·
Registered
Joined
·
349 Posts
The camshaft position sensor is located on the backside of the head, driver's side, and obtains it's signal from the exhaust cam. It is very difficult to see. It is bolted to the backside of the head and has an electrical connector.

It is very tight back there and probably is going to be difficult to remove. Hope this helps.
 

·
Registered
Joined
·
1 Posts
To remove the Camshaft position sensor - First remove the camshaft cover (after all items above the cover have been removed first) then remove the cap (two bolts) on top of the sensor. After this remove the two bolts on the back side of the sensor and lift off of the head. After this - disconnect the sensor from the wiring harness on the back side of the head.
I had the same problem with my sportage, i.e., code no. P0343. However replacing the sensor did not solve the problem. In addition I check the procedure outlined on the shop manual and that did not seem to help.
According to the manual check the following when this code appears:
1) Ignition off, disconnect the CMP (Camshaft) sensor connector and the ECM connector C118-2 and ECM harness connector C211-44 (resistance 0 Ohms) Is the resistance within specifications? Yes (mine was - went to stp 2) go to step 2. No - Open between harness connector C118-2 and ECM connector C211-44.
2) Connect ECM connector, Ignition On, measure voltage between C118-2 and ECM connector C211-44. Is voltage Approx. 12 V? Yes (mine was 5.0 volts- is this OK?) Short to battery voltage between sensor connector C118-2 and C211-44. No- Go to stp 3.
3)Ignition off, measure resistance between connector C118-1 and Grd (0 Ohms.) (mine is .755 Ohms - is this oK?)
question - Whats wrong? Is my values for stp 2 and 3 OK? Also my knock sensor code (P0326) comes on - could this affect the CMP Sensor - already replaced the CMP sensor. Still getting this check engine code.
Any help appreciated.
Reed
 
1 - 4 of 4 Posts
Top