Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have a 2001 Rio with 160K. I have a code that says Cyl. 1 misfire. When I start the car it idles rough and won't accelerate. It acts like its not getting enough fuel. Plugs and wires have been replaced. Could it be the two coil packs? Also it does the same thing if I start it and go immediately without letting it warm up. I'll get half-mile down the road the check engine light comes on and it starts running rough and won't accelerate. I can push it into neutral turn it off and restart it while rolling. Let it warm up another minute the check eng. light goes out and it runs fine.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Fuel pump or fuel filter check system fuel pressure if you can should be around 50 psi, check the connector's to the coil pack's they burn up. Also clean the IAC valve with carb cleaner cheap and easy to remove and do it may be sticking. Any cel codes?http://www.kiatechinfo.com/ free in the USA Good luck, Reguard's Ronjohn
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Can't remember the codes but do remember it said cyl. 1 misfire. I believe the plug wires pulg directly into the coil packs. I was wondering if the coils packs could be causing this. Could indeed be the fuel filter.
 

·
Registered
Joined
·
1 Posts
Just went through a simliar issue with mine except it was P0301 & P0302 for codes. Misfiring on both of these. check the very fine wires going into the bottom of the coil packs. Re did the wires as one was broken and sold the problem. The problems that i had were no power, ran really rough at idle but seemed to run fairly some once i was moving. If this is a rebuilt or engine replacement i would definitely take a look at these wires.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
I agree sound's like a good thing to check they left no room for the coil wires (low voltage) it was a tight fit no slack on mine also .
 
1 - 5 of 5 Posts
Top