Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Having some weird electrical issues with my Magentis. It started last weekend when the oil light came on, and then slowly faded away as I was driving (I checked, the oil level was OK). It came on again the next day and then faded away again, but the day after that the battery light came on with it. The stereo started cutting out next, and when we pulled over the car wouldn't start.

Had it towed home and replaced the alternator yesterday, and everything seemed to be OK. Took it for 3 drives and there were no issues. This morning the oil light came on again, though, and once again faded away before I got to work.

Could it be another bad alternator? A bad battery? I'm stumped on this one.
 

·
Super Moderator
Joined
·
9,553 Posts
Having some weird electrical issues with my Magentis. It started last weekend when the oil light came on, and then slowly faded away as I was driving (I checked, the oil level was OK). It came on again the next day and then faded away again, but the day after that the battery light came on with it. The stereo started cutting out next, and when we pulled over the car wouldn't start.

Had it towed home and replaced the alternator yesterday, and everything seemed to be OK. Took it for 3 drives and there were no issues. This morning the oil light came on again, though, and once again faded away before I got to work.

Could it be another bad alternator? A bad battery? I'm stumped on this one.
What made you decide to change the alternator?

It sounds more like a poor grounding - check the grounding straps between the battery and the chassis, and the engine and chassis.

I'd be too scared to drive a car when the oil light comes on, although in this case it looks like a false alarm.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Local mechanic suspected the computer was shutting down one system after another because it didn't have enough power to keep running, and the oil light was just first in the sequence. I was a bit worried about the oil light myself, but the way it faded away was strange, and when the battery light followed, electrical seemed to make sense.

Thanks - I'll get the grounding wires checked and see if that's the issue. I'd love it to be something simple (and cheap).
 
1 - 3 of 3 Posts
Top