Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2000 Kia Sephia LS
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I've had my 2000 Kia Sephia for almost a year now and it's had a rough idle since I bought it. When in park or neutral the vibration isn't very noticeable, but in gear it is very noticeable. I only experience any vibration when I'm stopped. The vibration becomes incredibly harsh when I turn on the air conditioning at any fan speed. Today I cleaned out the IAC with some throttle body cleaner and I also cleaned the butterfly valve in the throttle body but there was no improvement. Any suggestions?

EDIT:
Some info:
Mileage- Just a bit over 110k now. Almost 100k when I got it.

I replaced the spark plugs in the last week of May but I did not replace the wires and haven't since I got the car. I don't know when they were last replaced.

I haven't changed the transmission fluid yet.

I recently replaced the PCV valve, a front wheel bearing, a PS pressure line, and the fuel filter.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
I can see but others can't that you are located in SW Pa (USA). We are a "Global" forum dealing with many different versions of models (Sephia) and locations (climate).

We need more information before we can truly help you with your problem(s).
That's why filling out your CP area is so important.
OK...you have a 2000 Sephia 1.8L Automatic.... What's the mileage on the car? ...
When did you last replace the spark plugs and wires?
Have you changed the transmission fluid every 30k miles?
Transmission fluid going bad is a common problem with this car...and it could get worse..like loosing third gear... The transmission is a Ford/Mazda design known to have problems with gunk/goo build up from the old fluid reacting with the transmission parts. Poor idle is one of them.

Motor/transmission mounts are another problem that feeds back vibration that would normally be isolated from the driver. Any load (AC) on the engine will aggravate the vibration.

I'm sure others will chime in on suggestions also...
Dave
 

·
Registered
2000 Kia Sephia LS
Joined
·
2 Posts
Discussion Starter #3
Thank you. Edited to provide more info.

I have thought that the problem could be a mount but have not yet checked the mounts which aren't visible from the engine compartment. I will check them as soon as possible.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,121 Posts
How is the idle, what rpm is it without ac, and with ac.

A low idle can vibrate a lot of things preaty bad.
 
1 - 4 of 4 Posts
Top