Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
When I brake for an intersection or roundabout and then accelerate again for a second or so nothing happens so naturally I put my foot down a bit more and then suddenly it takes off like a rocket sometimes wheel spinning.

My feeling is that it is not changing down into first so when I put my foot down it realises that it is in the wrong gear and chops down.

The garage says that when the computer read out shows no error that there is no problem.

Does anyone else have this problem?

Can anyone help?
 

·
Registered
Joined
·
2 Posts
lag

this is typical of the 2.9 diesel I have installed a diesel chip from chip my diesel this has helped considerably and has helped when you first pull away .
Get the pro model as this give you more options when tuning easy to fit go to there site great service. you will not get rid of this delay altogether as this is the fuel delivery catching up after you have backed of but the chip makes a huge difference. take your time setting it up and you will be pleased with the result. Mine is set on all 5 low 7 med 6 high 3 hope this helps as that was one of the things that worried me.
 

·
Registered
Joined
·
4 Posts
When I brake for an intersection or roundabout and then accelerate again for a second or so nothing happens so naturally I put my foot down a bit more and then suddenly it takes off like a rocket sometimes wheel spinning.

My feeling is that it is not changing down into first so when I put my foot down it realises that it is in the wrong gear and chops down.

The garage says that when the computer read out shows no error that there is no problem.

Does anyone else have this problem?

Can anyone help?
I experienced same problem few weeks after I got my 2005 carnival.After some time it wouldn't accelerate at all even after pressing down the throttle.
Upon calling my mechanic he told me it was fuel filter, which I immediately removed, shaken vigorously and forcefully cleaned by blowing through the inlet.
After I reinstalled it, the vehicle zoomed off like never before.
I only clean it after a long journey and the problem had never repeated since.
 
1 - 3 of 3 Posts
Top