Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Kia Sedona 2003
Joined
·
79 Posts
Discussion Starter #1
MMM so close to working.

Drained flushed filled. Currently running with Thermostat out.
Not sure how to bleed, but jacked UK offside hig into the air to clear airlocks.
Very light froth of fine bubbles at rad cap when engine running with cap off.
Rev engine at temp eventually a temporary fountain will come from rad cap.
Run with rad cap on and system filled bubbles to expansion tank odd spurt of water.
Heater gets hot then cold

No mayonaise.
No smoke from exhaust.

Any suggestions, any other explanation for light froth of fine bubbles at rad cap than head gasket.

K seal or steel seal anyone recommend?

All input appreciated.

P
 

·
Registered
KIA SEDONA 2.9 CRDI L
Joined
·
29 Posts
Hi I ve not been on forum for a few months I had exactly the same issue with mine .Sorry to be the bearer of bad news but I would be 99per cent sure its you head gasket away .i tried k seal twice it work for a while and just blew through again that explains your heater running cold .Now the options are only if the injectors come out a new head gasket or if the injectors are stuck a replacement cylinder.i have one in my garage which i got i had it al cleaned up and skimmed .p m me if you are interested .
 

·
Registered
05 sedona 2.9crdi, nissan skyline r33
Joined
·
4 Posts
MMM so close to working.

Drained flushed filled. Currently running with Thermostat out.
Not sure how to bleed, but jacked UK offside hig into the air to clear airlocks.
Very light froth of fine bubbles at rad cap when engine running with cap off.
Rev engine at temp eventually a temporary fountain will come from rad cap.
Run with rad cap on and system filled bubbles to expansion tank odd spurt of water.
Heater gets hot then cold

No mayonaise.
No smoke from exhaust.

Any suggestions, any other explanation for light froth of fine bubbles at rad cap than head gasket.

K seal or steel seal anyone recommend?

All input appreciated.

P
hello did you manage to find out what the problem was??
 
1 - 3 of 3 Posts
Top