Kia Forum banner

1 - 11 of 11 Posts

·
Registered
2000 Kia Sportage 4x4 2.0 , 2006 Kia Sportage fwd 2.6 , 2005 Hyundai Tucson 2.6
Joined
·
5 Posts
Discussion Starter #1
2000 Kia Sportage 4x4 2.0. The vehicle ran fine and I stopped at the store come back out after about 2 hours and no start. I have checked everything , tested fuel pressure , spark, and keep getting 1307 code. Replaced sensor checked for continuity and all is fine.
I just don’t know where to start from here.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,151 Posts
What's the mileage and when last was the timing belt changed?

Spray starter fluid into the intake.
 

·
Registered
2000 Kia Sportage 4x4 2.0 , 2006 Kia Sportage fwd 2.6 , 2005 Hyundai Tucson 2.6
Joined
·
5 Posts
Discussion Starter #3
Timing belt changed 6 months ago. Mileage is 137,459. I’m the second owner this was our company vehicle. I tried starting fluid and still nothing.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,151 Posts
Timing belt changed 6 months ago. Mileage is 137,459. I’m the second owner this was our company vehicle. I tried starting fluid and still nothing.
Good idea to always describe any tests and results up front.

What all have you checked and tried?

A compression test?
 

·
Registered
2000 Kia Sportage 4x4 2.0 , 2006 Kia Sportage fwd 2.6 , 2005 Hyundai Tucson 2.6
Joined
·
5 Posts
Discussion Starter #5
Also I noticed that accelerator idle control is buzzing as soon as I turn the key on.
 

·
Registered
2000 Kia Sportage 4x4 2.0 , 2006 Kia Sportage fwd 2.6 , 2005 Hyundai Tucson 2.6
Joined
·
5 Posts
Discussion Starter #6
Compression test : fine
Ohm tested sensors: fine
Fuel pressure: fine
Spark plug and coil: fine
Replaced O2 sensors about a month ago
Replaced entire exhaust system and exhaust manifold (that was cracked) a year ago.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,151 Posts
Also I noticed that accelerator idle control is buzzing as soon as I turn the key on.
That is normal and a good sign if the Idle Speed Control valve (ISC / IAC) buzzes - it would also not prevent a start.

I would double check the timing marks, even though the compression is good.
 

·
Registered
2011 Forte SX 2.4L (thankfully MPI) A/T 144K miles
Joined
·
1,229 Posts
Did you check to make sure the butterfly in the throttle body is moving, and that the TB is not obstructed? If fuel, spark, and compression are as good as you've posted, then the only thing left is not enough air coming in.
 

·
Registered
'96 Camry v6 XLE, '00 Camry LE
Joined
·
2,190 Posts

·
Registered
2020 Kia Soul
Joined
·
9 Posts
2000 Kia Sportage 4x4 2.0. The vehicle ran fine and I stopped at the store come back out after about 2 hours and no start. I have checked everything , tested fuel pressure , spark, and keep getting 1307 code. Replaced sensor checked for continuity and all is fine.
I just don’t know where to start from here.
First, we would need to know......Will it turn over but not start or will it not even turn over?

Could be many things: Bad alternator, bad battery, bad starter motor, bad starter solenoid, bad ignition switch, bad (corroded) battery cable connection, bad battery ground at the engine, clogged catalytic converter, and many other things.
 
1 - 11 of 11 Posts
Top