Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i have a 1997 sportage im having problem with it getting warm and then intermittenly more often then not it will llose power i can put petal to floor n wont go it doesnt sputter but it did cause it to shake once in a while. i have checked plugs n they are burning good. it has never shut it self down yet however i usually cut it off n wait a minute or so n start it back up n then it runs good for a little while then problem comes back n i go threw same routine. it is an automatic mileage is 130000 or a little more. also on startin on a hill it will loose power every time even when motor is cold it will like fall flat on its face. i have never smelled fuel in the exhaust n i know its not the cat, cause it never smells like rotten eggs n it feels like its pushing pressure out the tail pipe. i did think it maybe the feul pressure regulator but i dont know how to check that, i also bought some chevron techron to run threw it, will try that in the morning. thanks again for any help yall can provide me.
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,692 Posts
Provided the back pressure test verified the CATs as OK (taken at front O2 bung,<3psi @2500rpm)

time to connect a LIVE DATA SCANNER.

COLD engine, (KOEO)
AIT (air temp)and ECT(coolant temp) must be with in 2% of ambient temperature
TPS, 0% at stop and rise smooth and steady as throttle is advanced
MAF, 0% with no air flow
Battery, 12.6vdc, fully charged.

Start engine.
ECT, must start to rise and attain and hold 180* at idle and 2000rpm
CL (ECU) must maintain at idle and 2000rpm
MAF, small reading at idle and rise steadily as throttle advances.
O2, (B1S1, precat), must start actively switching with no lean/rich bias...
LTFT, (long term fuel trim), close to 0%, +/-2 is allowable, if more, time to investigate fuel delivery/illegal air
Vacuum, at unregulated manifold port, 19-21”hg..with a dead steady needle, investigate jitter or bounce.

... Philip
 
1 - 2 of 2 Posts
Top