Kia Forum banner

1 - 8 of 8 Posts

·
Super Moderator
99 Kia Elan, 17 Ford Edge Sport, 15 Mustang, 08 Harley Nightrain
Joined
·
9,687 Posts

·
Registered
Joined
·
1 Posts
1999 Sportage EX Sport Utility 4x4 2.0l. Changed fuel pump, fuel filter, new thermostat and flushed/replaced coolant.. so it started, drove it for 3 days then the other day it started again but while it ran for 2mins I've started to hear the fuel pump slowed /wine down til it shut down and it stalled??? It wont start.. plz help
 

·
Super Moderator
99 Kia Elan, 17 Ford Edge Sport, 15 Mustang, 08 Harley Nightrain
Joined
·
9,687 Posts
1999 Sportage EX Sport Utility 4x4 2.0l. Changed fuel pump, fuel filter, new thermostat and flushed/replaced coolant.. so it started, drove it for 3 days then the other day it started again but while it ran for 2mins I've started to hear the fuel pump slowed /wine down til it shut down and it stalled??? It wont start.. plz help
Using the below link, please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature


https://www.kia-forums.com/threads/forum-rules.27240/


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 

·
Registered
2001 Sportage, FE DOHC Engine 5 SPD Manual Petrol
Joined
·
89 Posts
1999 Sportage EX Sport Utility 4x4 2.0l. Changed fuel pump, fuel filter, new thermostat and flushed/replaced coolant.. so it started, drove it for 3 days then the other day it started again but while it ran for 2mins I've started to hear the fuel pump slowed /wine down til it shut down and it stalled??? It wont start.. plz help
Weird, I can't even hear my fuel pump. You should check some electrical things. It sounds like somethings not matching up. The key turns on, activates the fuel pump relay, the fuel pump runs. Sounds like it's not getting the proper voltage, or it's sucking up dirt, slows down and quits.
 

·
Registered
Sportage Limited 2001
Joined
·
166 Posts
Need to see if you are getting enough amperage to the pump and a good ground. I use a 55 watt headlamp bulb at work to load test the fuel pump circuit. If it won't turn it on, it isn't going to run a pump. Then you just have to test the ground circuit or pump +voltage circuit.

2001 Kia Sportage Limited 2X2 USA
 
1 - 8 of 8 Posts
Top