Kia Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
hey u guys im back,, ive noticed when i turn on my wiper to clean my window, the liquid is not spraying on window it like the line is broken. the one that feeds from inisde engine to wipers.. does anyknow what is the name of that device.. not the actual wiper, and not the motor.. liquid is only coming out from one side of the wipers... thanks
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,100 Posts

·
Registered
Joined
·
27 Posts
When it is very cold outside the liquid may freeze and the pump stops working. It happened to me a couple of times. When the snow melted, the liquid sprayed on the windshield.
 

·
Registered
Joined
·
11 Posts
I need to find my 'winshield wiper Pump" I have no clue where it iscommon sense would tell me somewhere under the resivoir.

I have a 95 sephia
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,100 Posts
it should be connected to the washer resiviour.
 

·
Registered
Joined
·
11 Posts
thanks again man, it was connected to the base of it, unfortunately i had to take off the headlight, again, like yesterday for the horn, but I found it, 12 volts at the wire, pump is dead. NOw I'm going to call pep boys and find out if these things are universal and how much
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,100 Posts
shouldnt be much! at kia its 25 I think it was.
 
1 - 8 of 8 Posts
Top