Kia Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 95 Sportage and recently it started dieing while driving down the road. When this happens I leave the key in the on position, shift the vehicle into neutral, let the rpm's drop to zero, push in the clutch and shift to appropriate gear for the speed, let out the clutch and the car will restart. It will run for 20 to 23 seconds and then die again. When it dies I can leave it in gear without letting the rpm's drop to zero it will not start. TPS and MAF check out okay. Several times it has died when stopped and I got out and pulled and reinstalled the ECI relay and Fuel pump relay and it has started but not every time. I have replace the Idle Control Valve,fuel filter, fuel pump, coil, ignition wires about 20,000 miles ago and recently replaced the fuel pump relay. Any Iideas?
 

·
Registered
1998 Kia Sportage 2WD Base Model
Joined
·
306 Posts
My guess would be either a bad ckps or a vacuum leak close to the cylinders.best bet would to be to put a vacuum guage.on the capped port on the uoper manifold and verify good vacuum. If you read low vacuum you need to check timing and vacuum leak. If vacuum reads steady you have an electrical problem somewhere.

You can try unplugging the maf sensor to determine if the probem is vacuum related.
 

·
Registered
1998 Kia Sportage 2WD Base Model
Joined
·
306 Posts
My guess would be either a bad ckps or a vacuum leak close to the cylinders.best bet would to be to put a vacuum guage.on the capped port on the uoper manifold and verify good vacuum. If you read low vacuum you need to check timing and vacuum leak. If vacuum reads steady you have an electrical problem somewhere.

You can try unplugging the maf sensor to determine if the probem is vacuum related.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks DeeRock, I did find a vacuum leak and faulty Idle Control Valve, I replaced that valve less than 3 yrs ago. Idles smoothly now but some days it runs great and some days it will just die. Next project will be to check and clean all grounds. Pull TPS connector to see if I got a Check Engine Light and I didn't get one so it looks like I have some kind of communication problem with the PCM because I think I should have gotten a Check Engine Light.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,959 Posts
Bad "new" relay??...
Lots of "junk" relays out there at the auto parts stores..
AND the Sportages like only a few...
A relay failure can cause problems without setting a code also...
Dave
 
1 - 5 of 5 Posts
Top