Kia Forum banner

1 - 13 of 13 Posts

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #1 (Edited)
I decided to move this post I had in the "low thumping noise" thread to its own thread to see if it'll catch others attention

Hi, I'm new here and my reason to sign up was to see if anyone had the same problem I'm having.

I drive an 11 Sorento SX, premium package.

*Thumping noise*
Started noticing it around October of last year (I got my car in July '11), I mentioned to dealer, he didn't look at it but said maybe it was just the process of a cold start up. I believed him because it only happened in my morning start up. Still happening.


*Reverse light not lit and would not go stick to gear*

started last Tuesday. I put on Reverse to get out of parking lot. The letter R didn't come on the odometer screen then it automatically put the car to park but the screen did not say P. So I manually set it to park and then set back to Reverse, the R came on, i got out of parking lot. Set to Drive, gas peddle felt a little stiff when I put pressure on it. Didn't think anything of it so I went on my merry way. Gut feeling said something like I needed to restart the whole car, but i did not listen. This happened 3 times. Oh, 4th during the towing this morning.

*Engine shut down*
I was on the freeway, I was getting to about a quarter tank of gas so I decided to fill up because it was late and I was planning to sleep in the next day and not worry bout pumping gas. I came to a red light and felt a little fainted rattle before I noticed or heard the Key Engine light flashed. I looked down at the odometer and my PUSH START light was in green. My car was loaded with passengers, Husband and two kids at the time. I flipped the Emergency lights on, shut down the car completely and attempted to turn back on (JERK behind me didn't seem to noticed the E-lights cause he honked). Car restarted, I pulled into a gas station. Pumped my gas and got to my destination.


This morning I called the KIA Dealer and asked for a tow to there. The guy on the phone gave me the 800 road side number. I called them and they came to my house at the right ETA that was given to me. I got a call from the dealer and told me my car arrived. About an hour later he called back and said there's nothing wrong with the car (go figure) but he's going to check again. He called me back the next hour, nothing, he asked if he could pack in a few miles around the block then restart it the next morning to see if anything shows up.

Pending Update. I'm VERY sad about this. My Sorento is not safe and sound at home in my garage. :'(

Does anyone else have similar problems? What do you think it is? Any input is welcome, please. I'm at a loss. :-/
 

·
Registered
2011 Titanium Sorento SX - 39,000 miles since 03/2011
Joined
·
106 Posts
Sorry to hear this, but glad everyone is safe. I also have a 2011 SX, and just hit 20,000 miles yesterday.

For the thumping,I notice it daily on a cold start as well. I have seen others here on the board mention it, so I haven't thought much of it and do not think it is affecting the operation of the vehicle.

The other issues I have had are:

1. Backup cam only intermittently working, and then not working at all. They replaced the entire camera system hardware.
2. Sun-roof does not always operate. Luckily, it has been trying to open it, not close. So I have never been stuck with an open sun-roof.

Both these issues seem to happen in the heat. We have had a very hot summer here, with 90-100+ degree days. This is when I. Notice these problems the most.
I have had them both fixed multiple times. The most recent sun-roof issue seems to be ok for now, but I am still experience the backup camera issue intermittently.

For your Reverse issue,I have noticed that the car must be at a complete stop with your foot on the brake, in order to move the transmission control around (unless you are driving it in standard). A few times I have had to go back to park and the reverse again in order for it to kick in... I just figure an electrical issue. It always goes in on the second try, so I a. Not worrying too much about it.

The only "engine failure" I have had was my own fault. I did not keep my foot on the brake peddle long enough one day while starting it. The Sorento did not like this and started sputtering and making all kinds of noise. I am careful not to do that again.

Those have been my only issues since delivery in March 2011. We have not had any type of reasonable snow for me to drive around in,but I have tested the AWD on wet pavement and it kicks in wonderfully.

When I go for my oil changes, I make sure to tell them these issues so that they check them out, and document them. I would make sure you get some type of receipt documenting their investigation with their result findings. Then file it away, and if these things continue to happen, and the car becomes unsafe or undrivable, then you might have to take a different strategy. But they are always concerned and fix my vehicle up right whenever I have gone in, so the customer service is great at my Kia.

Best of luck, and let us know what you find out.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #3
so update..... not a good one on my end.

Just got off the phone with the Dealer, he said his tech guy put on some miles... left it over night. Ran some tests again this morning and.... NOTHING. a big NOTHING. BLAH! Guess I'll be picking up my car today before they close.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #4 (Edited)
Sorry to hear this, but glad everyone is safe.
1. Backup cam only intermittently working, and then not working at all. They replaced the entire camera system hardware.
Oh yes, this happens with my backup cam too. I was planning to take it in to have it looked at but ever since then it's been "behaving".

Sorry, can't relate to your sunroof issue because I do not have that feature on mine, which was a good thing [dealer said] because I wouldn't have been able to install a DVD player for the kids.

Dealer said he contacted KIA to get some info and they said they have nothing on it. I smell BS so I'm going to find the number and call them myself.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #5
Sorry to hear this, but glad everyone is safe.
The only "engine failure" I have had was my own fault. I did not keep my foot on the brake peddle long enough one day while starting it. The Sorento did not like this and started sputtering and making all kinds of noise. I am careful not to do that again.
You know what, I think the Sorento does have a mind of its own too and "she" does not like my husband too much. LOL I think I'm being punished for lending it to him for a week while I had to take the Optima in (his work schedule is weird) for maintenance.
 

·
Registered
2012 Sorento EX AWD CRDI; 2007 Sportage EX CRDi 4WD; 1967 Mercedes 250S; 1958 DKW 3=6
Joined
·
372 Posts
You know what, I think the Sorento does have a mind of its own too and "she" does not like my husband too much.
Damn! Mine appears to have no mind at all and seems quite happy at my wife borrowing it and driving around from time to time!

On a serious note, The north American Sorentos do seem to have few issues, mainly relating to the electronics, and by judging from the board here most get resolved eventually to the satisfaction of the owners. So keep your faith. The Sorento is a good vehicle. One of the main reasons why the issues don't get resolved quickly without frustrating the owners is the dealers apparent unwillingness to accept that something is wrong which results in a somewhat offhand approach to the problem. Since yours is a somewhat major issue that can be regarded as a matter of safety I think you might be better off contacting KIA directly.
 

·
Registered
2017 Sportage SX AWD
Joined
·
34 Posts
Sorento11tbn,
The issue is more serious that you think, I have seen your post in my thread. Since my incident, my sorento has been in and out of the shop for 6 times already.

Now I have suddenly developed a grinding noise on turns and the car slips before it comes to an entire stop. The dealer said that the rear differential has gone bad and are working on replacing it.

I do not know how a brand new car will have that many problems. Anyhow I decided enough is enough and I am in the process of a law suit against Kia. I have had my sorento for 3 months now from which two of them it spent in the shop.

I would advise you to take your car to a new dealership until they figure out the problem. It seems like they are using the trial and error method with me.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #8
Damn! Mine appears to have no mind at all and seems quite happy at my wife borrowing it and driving around from time to time!
lol, I'm starting to think that Sorento's are only meant to be driven by females :p

Thanks for your response guys, I really appreciate it and I do agree with you on getting a second opinion/observation on my car. The nearest Dealer was the one I took my car to (one hour), and the one I purchased my car is 2hours away. I would take the extra hour to get there but I'm a bit skeptic on having it shut down on me again at a dangerous time and place.... 800 road side would only take to the nearest dealer (I used this strategy on the current issues)

This is a good car, it's just unfortunate that these things are happening to a brand BRAND NEW car, I completely agree with you. :-( I'm crossing my fingers for a happy outcome.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #9 (Edited)
*Update*

I got my car back a few hours ago. When I got there, I asked the service rep to follow me out to my car and watch while I turn my car on and shift it in gear. I shifted to Reverse and NOTHING (behaving normally). Shifted to all other gears. NOTHING. But I did noticed that the letter font on the odometer (i.e., R) is a little different than before. I'm not so sure but to me it looked kind of different. So I got home and I asked "doxcyguy617" if he could take a picture of the letter on his odometer and show me since we both have the same car model and year. If anyone can beat him to it and show me, i'd appreciate it :) If in fact it did changed, maybe they reset something and not tell me because now the shift gears are fine and normal.

I did not drive the car home but my husband did because he didn't want anything to happen to me (he's taking the bullet), so I can't really tell how it's operating... I'll do that tomorrow with some errand I need to run.
 

·
Registered
10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Joined
·
1,412 Posts
Sorento11tbn,
... It seems like they are using the trial and error method with me.
What do you expect them to do? Its extremely difficult to diagnose a problem if the problem doesn't exist and cannot be duplicated.
 

·
Registered
2012 Sorento EX AWD CRDI; 2007 Sportage EX CRDi 4WD; 1967 Mercedes 250S; 1958 DKW 3=6
Joined
·
372 Posts
*Update*

But I did noticed that the letter font on the odometer (i.e., R) is a little different than before. I'm not so sure but to me it looked kind of different. So I got home and I asked "doxcyguy617" if he could take a picture of the letter on his odometer and show me since we both have the same car model and year. If anyone can beat him to it and show me, i'd appreciate it :)

Why don't you post a picture of yours so that we can all comment on it?
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #12 (Edited)
Why don't you post a picture of yours so that we can all comment on it?
OF COURSE! Why didn't I think of this!? Sorry, maybe I'm over worrying about it and it slipped my mind. Lol

Well, now a picture wouldn't prove anything really because the Reverse problem still exists, this time a split second delay compared to the other gears that I shifted to. But I'll attach a picture anyway....


I thought the line from blue arrow would be the same as the line in white arrow. Or maybe because I've been staring at my husband's odometer font for too long when we swop cars for a week.

Took her out for a trip around town to run some errands. Seems to be running fine.... for now. I'm cringing for that moment of another shutdown. :ph34r:

BTW, the thumping is still there at start up, paper work said they didn't hear anything. Maintenance drove MY car home to HIS house and then back to work the next morning.
.
 

·
Registered
Sorento11 SX premium package wDVD; Optima08 LX,
Joined
·
11 Posts
Discussion Starter #13
Wow, right after I posted the previous post. I got a follow up call from KIA asking how the service went and if they were able to duplicate the problem. I responded how I updated you guys. She advised me to take it back to the dealer and have them do further diagnoses.

I mentioned that I would need a car for this weekend because I have to leave out of town. Rental/Loaner is outside of the warranty so she can't guarantee a car for me while it's in service but she will have my case up for review and see if I'll qualify for one. Who knows how long that'll take. Ai-yai yai....
 
1 - 13 of 13 Posts
Top