Kia Forum banner

1 - 10 of 10 Posts

·
Registered
car
Joined
·
4,209 Posts
Discussion Starter #1
I have had my 04 Optima LX for 15 months now. It is going to turn 10K miles tomorrow. What a great car. It rides so smoothly and I love the way it looks. If I had to do it all over again I wouldnt change a thing. I would buy another one. Just thought I would share all of that with you. :beer:
 

·
Registered
2007 Optima, 2007 Sorento
Joined
·
716 Posts
Hi Spec SX, my 2002 Optima LX V6 with just a bit over 12,000 miles has served me well these past years. I haven't had any complaints and am very happy with my Kia. Friends are still impressed with its ride, comfort level, performance and quality build. Its exterior and interior look showroom new and love the silver paint very much. I added wood trim to the instrument cluster and center facia that holds the radio, vents, and temp controls. Wood trim came already on the center console and door armrests. Made a big difference in my enjoyment of the already good looking interior. My Kia is serviced only by Kia in Rock Hill, SC and I am extremely pleased with the shop and its staff. Good maintenance is a key to keeping a Kia running well. Many buy them and don't care for them. Most of us on this forum take pride in our autos and service them right.

Long live our Kias Spec SX!! I'm not selling mine... ever. :beer:
 

·
Registered
car
Joined
·
4,209 Posts
Discussion Starter #3
Mine gets serviced either by me or my dealer. It gets cleaned inside and out atleast once a week. I wax it about 4 times a year. I agree keeping them maintained will make them last. Out of all of the cars I have owned its one of the best. I dont plan on getting rid of mine any time soon. If I did someone would be getting a great car and I would probably regret it.
 

·
Registered
2004 Kia Optima
Joined
·
1,980 Posts
Awesome!!! Mine has 35,000 miles and it's running pretty well.. currently I'm having issues with the idle.. it's dipping but not too bad.. but it should idle bad after a year.. wierd.. I know it has to do with mis-firing.. but we'll see.. STILL love the optima! W3RD!!! :57:
 

·
Registered
2004 Kia Optima
Joined
·
1,980 Posts
OK update... the bad idle was due to the spark plugs that I had installed... when I installed the OEM plugs back in the problem disappeared! W3RD!!! :57:
 
1 - 10 of 10 Posts
Top