Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My '08 Rondo, EX6 decided a couple months back to stop blowing cabin air. I took it into a mechanic and was told that it was just the blower motor.

I have since (given the relative ease of replacing a blower motor) gotten 2 from 2 different junk yards and neither one has worked.

Checking the last one, it does have minimal resistance, so it should work. Also, I checked the output voltage to the connection for it, it is at a constant 13.68-ish VDC, but this is no matter which setting I put it on.

When turning to AC, the AC still turns on, so that is working, but I have got to be missing something, as I have motors that should work, but no variation in the voltage to the motors when using the manual dial to change speeds, and I have no movement at all of the blower motor.

Any help and guidance would greatly appreciated, especially with the summer months on the horizon.

Thanks.
 

·
Super Moderator
1995 Procharged Mustang Cobra, 2021 Sportage EX
Joined
·
4,507 Posts
How about a brand new blower motor? Have you checked the blower motor resistor?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
How about a brand new blower motor? Have you checked the blower motor resistor?
trying to avoid a brand new one, no, I had thought of the resistor, but I have no idea where it is to be able to check it. Given the fact there is no change in the voltage, it would make complete sense if that was the problem.

Any idea where it is located?
 

·
Registered
2014 Kia Soul, 1.6hdi auto, in Mixx trim, White over Powder Blue
Joined
·
650 Posts
It's under the glovebox in a UK spec RHD model so possibly under the steering column on your side of the pond, unless they move that around to fit the column in of course!
 
1 - 4 of 4 Posts
Top