Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I have 110k (65,000 miles) km on my car and recently had the timing belt changed, along with 3 other belts. Anyway there was an awful squeal before they were changed, and it seemed to be fine for about a week then it returned. I took it back to the garage and they re-tightened the belts and again, it purred for about a week until the weekend. It squeals when I'm turning, doesn't seem to matter if I'm turning the wheel full range or not. It also seems to squeal when I first start the car. Anyone have ideas what it could be? Thanks.
 

·
Registered
Joined
·
18 Posts
Sounds like the belt is squealing whenever your power steering pump is under load. I had a similar issue with my '03 Rio, whenever I turned on anything electric the extra load on the alternator made the belt squeak AND it also squealed when I started the car up and the engine and belt were cold. In my case the alternator bracket was broken and wasn't allowing the belt to tighten enough (my dealer broke it and tried to hide it...)

Unfortunately I don't know much about the '06 and up Rios, I don't know what your belt configuration is but I'd start by seeing if the belt for your p/s pump is loose or not, it's possible they used the wrong sized belt (being lazy) and the adjuster is maxed out. You could try spraying some belt treatment on your pulleys to clean them and dry them out, it's possible they spilled something on the pulleys when they did your timing belt and it's slipping.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for the reply! It's going in again tomorrow. It's highly annoying, this is the 3rd time that it's in for the exact same thing.
 

·
Registered
Joined
·
18 Posts
Good luck! I know how embarassing/annoying it can be to drive around like that!
 
1 - 4 of 4 Posts
Top