Kia Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 07 spectra with auto trans, it does not want to start. It turns over, sometimes it takes 15 tries to get it to start. it has 170000 miles and I have never had a problem with it before. When it starts it just suddenly takes off like somebody flipped a switch. It runs well, still gets good mileage. I thought at first maybe a fuel pump problem, but when it runs there is no fuel shortage, goes up hills at highwy speeds no problem. I am not familiar with working on this car at all. What and where should I start looking to figure this out?? Any help would be much appreciated!!

Thanks

Rob
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,922 Posts
Rob...
Have you checked for OBDII codes? They may point the way...
What have you replaced? Plugs? Wires? When?

You said "it has 170000 miles and I have never had a problem with it before"

Have you replaced the timing belt? It should be replaced every 60k miles. Hopefully so... It could be very sloppy and throwing off the timing... If it breaks you will have MAJOR engine damage.
These are very good engines "if" maintained properly...They have been known to go 300K+.
Dave
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,922 Posts
Codes would tell...
Dave
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I replaced the plugs and wires eariler this year. It is due for a new timing belt, I put it in my budget to do this month, but now I have to fix this first. It had never showed any warning lights. I dont have a way to pull codes yet, will have to look into that. could there still be codes without any warning lights??? It just seems odd to me that it turns over as I try agin and again, then suddenly it takes off and runs with no problems. I am at a loss. I called a local Kia dealer and all they suggested is to change fuel filter. I would think if it was the filter it would cause problems all the time not just at starting. I am wondering if maybe a short somewhere??? I have read about the evap causing problems, is there a way to test it?

Thanks

Rob
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,922 Posts
Go to AutoZone and ask...It's free!
and yes there can be codes without the check engine light.
Only the worst errors turn on the MIL light.
Dave
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
So went to Autozone and they hooked up their code reader, didnt have any codes at all. I did notice today that if I resarted it fairly quick it started easier, the longer it sets the harder it is to start. I am gonna try to get a fuel pressure tester and check fuel pressure. I would think if it was the fuel pump or filter it would give me problems after it started too but once it starts it runs just fine. Any other suggestions that I might want to check???

Thanks

Thanks
 

·
Registered
2008 Rio LX, 2007 Honda Shadow (Bike)
Joined
·
74 Posts
Sounds like the fuel system is draining back to the tank when off. It would take multiple tries to re-prime the system if this is the case. There should be something that acts as a check valve to prevent drain back. Possibly in the pump itself. You can diagnose with a pressure gauge.
 

·
Registered
Joined
·
13 Posts
if you are un sure about when the timing was done last that would be my first priority. i would then start with upgrading to a newer battery! passibly some sensors, or it may be time to have an over haul done on your engine. how long have you had the car? ar you the original owner? how well was it maintained before you got it if your not the original owner? if the battery is not keeping the correct charge, it will have an effect on how the car starts. i had a small battery in my kia from the kia dealership them selves and it was having a problem starting until i got a battery from work that was x2 the size of the one that was in my car to begin with. but i agree, go to autozone and see if any codes are being tripped. get that timing belt done asap, if it breaks, you take a chance on warping your heads and it will ruin your engine to the point to where your either going to have to get it re-worked or have to replace the engine its self. good luck and i hope this helps.
 
1 - 13 of 13 Posts
Top