Kia Forum banner
1 - 9 of 9 Posts

·
Registered
Taurus, Kia Rio, Honda CB350
Joined
·
15 Posts
Discussion Starter · #1 ·
'05 Rio, 60,000 miles. Had TB replaced recently. When I fill up the tank the engine is hard to start. Cranks way too long before it finally fires and then dies. Does this 2 or 3 times and then starts and runs fine. It only does this when I stop for gas. Between fill ups it starts and runs good. Recently started showing 0170 and 0171 codes. And idling rough.
This car was bought used 1 1/2 years ago so history is unknown on it. Ever since purchase it has thrown a 0455 code- gross leak, but nothing has ever been found.
Please give me some ideas.
 

·
Registered
Taurus, Kia Rio, Honda CB350
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks for the reply: I replaced the gas cap twice in the past year. The seal looks fine on it. The hoses have all been gone over a couple of times. The local shop owner cleaned the MAF yesterday while it was there. He said he cleaned the throttle body and checked the IAC valve. He is at a loss and so am I.
 

·
Registered
Taurus, Kia Rio, Honda CB350
Joined
·
15 Posts
Discussion Starter · #8 ·
A knowledgeable friend came by tonight and checked this. He found two bad solenoids/valves. Tank purge valve and Tank vent valve. Only time will tell if he got it fixed. Thanks for all the help folks.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,022 Posts
Sounds like he found your problem Kudos to him. Get him to post on this site if you can. We need the help here any help is great. Reguards Ronjohn
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top