Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have an 03 Sorento, which started running bad lately. I went to the local Advance Autoparts to have the codes read. And all it said was left bank lean. I'm assuming this is pointing towards the O2 sensor(s)? There are 4 of them, so instead of paying the local shop $250 to replace one, I went ahead and ordered all 4 from Rock Auto for $150. The 2 upstream showed up today, so I put them in. I noticed that the 02 sensor on the left side did look like a lean running spark plug(meaning it's color was really light brown). the one from the right side looked about normal.
But the car isn't running any better. If you step on the gas, it bogs way down stumbles and backfires through the intake. It's getting really bad gas mileage. If the downstream sensor doesn't fix it, can I get some ideas on what else to look at? I really don't have the money to take it to a mechanic for a $100 diagnosis.

Thanks in advance
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,365 Posts
Lean means either not enough fuel or too much air. That being said it could be a vac leak or fuel pressure. Does it idle smooth? A vac leak could be a hose has come off or has cracks or splits. You need to have a fuel pressure and flow test done on the pump. If it has an original fuel filter it may need changing. Your next step may be a quality mechanic if you can't do this yourself.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
no, it doesn't idle very well. it's not a surging idle like you would have if the TPS was bad. But not bad enough to suggest a vacuum leak. Its almost like its missing a cylinder or two.
 
1 - 3 of 3 Posts
Top