Kia Forum banner

1 - 7 of 7 Posts

·
Registered
03 Sedona
Joined
·
13 Posts
Discussion Starter #1
My 03 has developed some type of issue with shutting off on its own after running for several minutes. If you let it sit for an hour or so it will start back up and run for another few minutes/miles and shut off again, yes the cel comes on but I dont have a reader, Ill have one tomorrow so I can read the issues hopefully ya all can give me some help?
 

·
Registered
03 Sedona
Joined
·
13 Posts
Discussion Starter #2
Ok got the codes out of it,,,, had 5,,,, (2) P0320, (1) P0335, and (2) P0500. The 320 is an engine speed input circuit issue, the 335 is a crank sensor issue,, the 500 is vehicle speed sensor, Id say the 500 has nothing to do with shut off and honestly the wife told me her speedometer has been acting up for a bit now. So can I assume the issue is being caused by the 320 or 335? Is it possible that one of those 300 codes is causing the other?
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,930 Posts
I know that the "Crank Angle Sensor" on 2.7L V6 engines cause a lot of problems (P0335). I don't know if this is a "problem" on the 3.5L V6 engines but it's worth looking into. The three wires coming off the sensor have plastic insulation that drys out, cracks, and falls off..allowing the wires to either touch each other or touch the engine block...LOTs of internittent stalling...
The P0320 could also be a bad speed sensor on the transmission or a bad connection on the plug that connects to it.
Dave
 

·
Registered
03 Sedona
Joined
·
13 Posts
Discussion Starter #4
OK, finally got the timing belt changed, while I was at it I also did the water pump, and the crankshaft sensor,,,, what a PITA. Anyways,,,, 154k on that belt, man am I lucky! Thanks to the site I saw 90k for a belt change and its a crash and smash engine when it lets go, so I consider myself very lucky!

Ive had it running and it hasnt yet shut off on its own, however the P0320 code is still popping up and I notice the tach is reading real low,,, so where is this sensor located?
 

·
Registered
03 Sedona
Joined
·
13 Posts
Discussion Starter #6
Just a follow up and close to the shut off issue,,, been a few weeks now and the vehicle operates without shutting off so looks like the crankshaft sensor was the culprit.
 

·
Registered
03 Sedona
Joined
·
13 Posts
Discussion Starter #7
whats the best price for a cambelt set for a sedona 2.9.diesel any help appreciated
Best thing is to call every supplier in your area and a dealer, compare and decide. Diesel Sedona,, never saw one in the US, nor would I want to own one with diesel being .60 a gal higher than gas in my area on average. Good luck.
 
1 - 7 of 7 Posts
Top