Kia Forum banner

1 - 16 of 16 Posts

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #1 (Edited)
My kia Rio bogs and shutters normally in the morning just before hitting full operation heat,, sometimes it does it after driving it all day.. i replaced the MAf, plugs, wires and coils. plug gab is .30. what is this problem?
 

·
Registered
Ford Escort '01, Kia RIO '03
Joined
·
1,372 Posts
Please fill out your profile as to general location and model. It really does help.

Do you live where you have lots of moisture from condensation dripping down on the wires from the motor cover. If you live in the desert it a non issue tho.

What brand of plugs did you use, Kia's reakky like NKG.
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #3
Its possible i guess.. I live in Nova Scotia Canada. its a at random thing now.. somedays it won't and others it does. it use to be bad in the morning but after i put the new parts on its better. The car has a different motor but it had almost the same kl on it as my old motor. 165000k.
 

·
Registered
Ford Escort '01, Kia RIO '03
Joined
·
1,372 Posts
I had this same problem with mine. My solution was to get the engine up to temp so everything was dry. Then with the engine off I sprayed the wires with silicone spray, I still may have the condensation but have no problem with how the engine runs.
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #6 (Edited)
I have a 2002 Kia Rio RX-V 1.5L. So i have been having a problem with it bogging out at times. I replaced the maf plugs and wires. Plug gap 0.30 and today i get a ODB2 code reader and it tells me p0132. i changed the o2 sensor and it still does it. Now what? harness, front cat change? i have both as spares.



Now i get a p0032. i had a used o2 but it was good because it was in my old motor before the timing belt broke. maybe ill try a new one?

I have a 2002 Kia Rio RX-V 1.5L. So i have been having a problem with it bogging out at times. I replaced the maf plugs and wires. today i get a ODB2 code reader and it tells me p0132. i changed the o2 sensor and it still does it. Now what?
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #8
It was just laying here and it was almost new.. only 4months old.. so i figured there's no harm in trying it out to see if i get the same old code. but im going to get a new one Monday.
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #9
Will the #2 o2 sensor work on #1 so i can hard wire it? i notice that the 1st o2 wires are not long enough to do it.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Yep if you look up the parts online for universal they are the same thing just oem have the correct wire length and connector same pinout for each just different color wires make sure you get the wire color correct for upstream and and downstream
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #11
So it still bogs after driveing it today. I checked the wires out everywheres and they seem really good. Can the wires rot inside the O2 plug in a way that i wouldn't see it? Is there something im missing here? maybe the CAT?
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #12 (Edited)
Can anyone help me with hardwireing down stream O2 in the up stream spot?(What color wire to what color wire)

thanks to everyone who has taking some time out of their day to help me out.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
One thing i forgot to mention in my PM what about the fuel filter and fuel pump ever changed the filter or checked the pump pressure. Just a thought. Reguars's Ronjohn
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #14
Iv read that alot and was thinking that tell i got the code. so it could still be something back that far?
 

·
Registered
1G Kia Rio 2002
Joined
·
30 Posts
Discussion Starter #15
Today is the 4th day driving it after putting my other O2 in. Its been sunny and nice for 3days and no shutters.. Im sure its something to do with water now. So when it rains well see if it starts again. I still have code p0032. but it runs just fine.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
So which sensor did you use? Did you hard wire it or not? Is it a pending code on your scanner, ther is a difference when clearing codes do both clearing functions and see if it comes back. Reguard's Ronjohn
 
1 - 16 of 16 Posts
Top