Kia Forum banner

1 - 11 of 11 Posts

·
Registered
2002 Kia Rio
Joined
·
6 Posts
Discussion Starter #1 (Edited)
I have an 02 KIA Rio with a 1.5 motor it has a rough idle and some rpm issues when i have it scanned it says misfire in cylinder 3,4,&2 then says random/multiple cylinder misfires then says cylinder 1 misfire, o2 sensor circuit malfunction (bank 1 senor 1) and lastly idle control system rpm HIGH. i have put a new coil pack, plug wires, plugs, o2 sensor bank 1 sensor 1, and it has a new alternator. please help me out.
 

·
Super Moderator
1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Joined
·
4,426 Posts
The hraness that plugs into your coil, what did it look like? Did it plug in good, nice and clean connection?
 

·
Registered
2002 Kia Rio
Joined
·
6 Posts
Discussion Starter #3
is it oval and has 2 wires there are 2 of the clips going to the coil pack one goes to plug wires 1 & 4 and the other goes to plug wires 2 & 3 and yes the connection is good
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,924 Posts
You need to have the car scanned for engine codes..
Advance or AutoZone will do it for free..
Then post them here..
Dave
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Did you have good power before these problems arose no problems climbing hills. Clean the IAC valve. Check/clean the intake component's make sure the throttle body is clean and the cable is adjusted properly and correct. The hose that goes from the PCV to the intake get's brittle and leaks check that out also. Good luck and keep us informed. http://www.kiatechinfo.com/ for service materials to help you. Reguard's Ronjohn
 

·
Registered
2002 Kia Rio
Joined
·
6 Posts
Discussion Starter #6
I Have had the car scanned three times in the last three days and the codes that have come up are as follows: P0303-Cylinder 3 misfire, P0304-Cylinder 4 misfire, P0302-Cylinder 2 misfire, P0300-Random/Multiple cylinder misfire, P0301-cylinder 1 misfire, P0130- o2 sensor Circuit malfunction (bank 1 sensor 1), P0507- idle control system RPM HIGH, P1166- manufacturer controlled fuel and air metering, those are all of the codes that pop up
 

·
Registered
2002 Kia Rio
Joined
·
6 Posts
Discussion Starter #7
i need a few questions answered if anyone could help me please answer them please..... How many pounds of pressure is in each cylinder for a compression check?? What does the fuel pressure need to be in the fuel rail?? What is the resistance for the fuel injector???? Lastly where is the PCM located??? Please answer asap and also is there any books that would help me with this for example like a Haynes book?? Just makeing sure everyone knows it has a 1.5 motor!!
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Fuel line pressure 46-51 psi. Fuel injector coil resistance 13.5-15.5 ohms at 68 degrees F. Compression is 184 psi. A little low (20 Psi) I would think is not a problem. Ok the ecm is located on the drivers side front up above the the hood opener on the left on the wall. I bought the kia book's when i bought the car new i don't Know of hanes or chilton's books but, http://www.kiatechinfo.com/ service info same as the books free to usa resident's just have to register. I hope this help you somewhat. The spec's i quoted are out of my book's. Good luck. Reguard's Ronjohn. Sorry I missed the p1166 check your cat's for blockage I had the same issue with misfires and low power my second cat was blocked at 134K.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
The site helped me alot ask dave's spectra he gave me the idea. I changed the plugs/wires/ fuel pump/ fuel filter/ air filter/ and a whole lot of other thing's. I had no power going up hill, idle was very bad and could not get over 3k in park. I disconnected the pipe between the cat's and what a differance. My 2nd cat was blocked not saying your first isn't but that helped me. .30 is the proper gap on the plugs. Hope this helps and don't think the ngk's are the proper plug's My 02 run's just fine on the autolite platimum plugs. PM me if you need help. And don't forget http://www.kiatechinfo.com/ for service materials good luck with it. Reguard's Ronjohn
 
1 - 11 of 11 Posts
Top